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Preface

Maple Software

MapleTM software is a powerful system that you can use to solve mathematical problems from simple to complex. You
can also create professional quality documents, presentations, and custom interactive computational tools in the Maple
environment.

You can access the power of the Maple computational engine through a variety of interfaces.

Interface Description

Standard (default) A full-featured graphical user interface that helps you create electronic documents to show all
your calculations, assumptions, and any margin of error in your results. You can also hide the
computations to allow your reader to focus on the problem setup and final results. The advanced
formatting features lets you create the customized document you need. Because the documents
are /ive, you can edit the parameters and, with the click of a button, compute the new results.
The Standard interface has two modes: Document mode and Worksheet mode.

Classic A basic worksheet environment for older computers with limited memory. The Classic interface
does not offer all of the graphical user interface features that are available in the Standard
interface. The Classic interface has only one mode, Worksheet mode.

Command-line version A command-line interface for solving very large complex problems or batch processing with
scripts. No graphical user interface features are available.

Graphical user interfaces containing windows, textbox regions, and other visual interfaces,
which gives you point-and-click access to the power of Maple. You can perform calculations
and plot functions without using the worksheet.

MapletTM Applications

This manual describes how to use the Standard interface. As mentioned, the Standard interface offers two modes:
Document mode and Worksheet mode. Using either mode, you can create high quality interactive mathematical docu-
ments. Each mode offers the same features and functionality, the only difference is the default input region of each
mode.

Shortcut Keys by Platform

This manual will frequently refer to shortcut keys and command completion when entering expressions. The keyboard
keys used to invoke these features differ based on your operating system.

The keystrokes given in this document are for Windows. There will be differences for other platforms. If you are using
a different platform, see Shortcut Keys.

Command Completion

¢ Esc, Macintosh, Windows, and Linux
» Ctrl + Space, Windows

o Ctrl + Shift + Space, Linux

Begin entering a command in a Maple document. Press the Esc key. Alternatively, use the platform-specific keys. For
Windows, press and hold the Ctrl key and then press the Space bar.

For more information on Command Completion, see Command Completion (page 33).

In This Manual

This manual provides an introduction to the following Maple features:

» Ease-of-use when entering and solving problems

xiii
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* Point-and-click interaction with various interfaces to help you solve problems quickly

* Maple commands and standard math notation

+ Clickable Math™

* The help system

* Online resources

* Performing computations

* Creating plots and animations

* The Maple programming language

+ Using and creating custom Maplet applications

* File input and output, and using Maple with third party products

¢ Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft website at
http://www.maplesoft.com

Audience

The information in this manual is intended for first-time Maple users and users looking for a little more information.

Conventions

This manual uses the following typographical conventions.

* bold font - Maple command, package name, option name, dialog, menu, or text field
* italics - new or important concept

» Note - additional information relevant to the section

* Important - information that must be read and followed

Customer Feedback

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact sup-

port@maplesoft.com.


http://www.maplesoft.com

1 Getting Started

Don't worry about your difficulties in Mathematics. I can assure you mine are still greater.
~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating the total cost of our purchases to the complex

calculations used to construct the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an accessible and complete form. That tool is Maple.

1.1 In This Chapter

Section

Topics

Introduction to Maple (page 1) - The main features of Maple's
Standard Interface

Starting the Standard Document Interface

* Entering commands and mathematical expressions
* Toolbars

+ Context Panel

* Copy and drag keys

* Saving Maple documents

Entering Expressions (page 13) - Methods of entering
expressions in 1-D and 2-D Math

» Execution groups

* Math Mode and Text Mode
+ Palettes

* Symbol names

* Toolbar icons

Point-and-Click Interaction (page 24) - An introduction to the
point-and-click features in Maple

+ Assistants

» Tutors

+ Context Panel
» Task Templates

» Exploration Assistant

Commands (page 31) - An introduction to the commands of the
Maple language

+ Using commands from the Maple library
+ Entering commands

* Document blocks

The Maple Help System (page 36) - Accessing help on
commands, packages, point-and-click features, and more

* How to access help for Maple features
* Interacting with help pages

+ Viewing and interacting with examples

Available Resources (page 39) - Both online and from within
Maple

» New user resources, including tutorials and the Maple Portal
» Examples

* Maple website resources

1.2 Introduction to Maple

Working in Maple

With Maple, you can create powerful interactive documents. The Maple environment lets you start solving problems
right away by entering expressions in 2-D Math and solving these expressions using point-and-click interfaces. You
can combine text and math in the same line, add tables to organize the content of your work, or insert images and sketch
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regions. You can visualize and animate problems in two and three dimensions, format text for academic papers or
books, and insert hyperlinks to other Maple files, websites, or email addresses. You can embed and program graphical
user interface components, as well as devise custom solutions using the Maple programming language.

W& C:\Users\Default User\SampleDocument.mw - [Server 3] - Maple 2019 EI@
File Edit View Insert Format Table Plot Teools Window Help A
DEHE= %5 o B T>= == @ M1 OHC & AQ @ |search Alt+5
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B Favorites a ’ Math |'I'|mesNewthman ~|[12 ~] B I u |§|§:: lvﬂ EE;E &
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Expressi —
¥ Depresson P42x—63 | F—dx+21 _ F—6x+37 Pplot([ seq(Bessell (n.x).n=1.4)1.x=0.10.filled)
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Figure 1.1: The Maple Environment

Starting the Standard Document Interface

To start Maple on:

Windows From the Start menu, select All Programs — Maple 2021 — Maple 2021.
Alternatively:

Double-click the Maple 2021 desktop icon.
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Mac 1. From the Finder, select Applications and Maple 2021.
2. Double-click Maple 2021.

Linux Enter the full path, for example, /usr/local/maple/bin/xmaple
Alternatively:
1. Add the Maple directory (for example, /usr/local/maple/bin) to your command search path.

2. Enter xmaple.

When the first Maple session opens, a Start Page displays shortcuts to useful tasks and topics.

To start a Maple session:

* In the Start Page, select New Document or New Worksheet. A blank document displays.

or

* From the File menu, select New, and then either Document Mode or Worksheet Mode. A blank document displays.

You can opt to start Maple with a blank document instead of the start page. You can also replace the default start page
with a custom start page. For instructions, refer to the startpage help page.

To invoke the Start Page at any time, click the home button (1) on the worksheet toolbar.

Document and Worksheet Modes

Maple offers two modes, Document Mode and Worksheet Mode. Using either mode, you can create high quality inter-
active mathematical documents. Each mode offers the same features and functionality; the only difference is the default
input region of each mode.

Document Mode

Document mode uses Document Blocks as the default input region to hide Maple syntax. A Document Block region
is indicated by two triangles located in the vertical Markers column along the left pane of the Maple Document, |

If the Markers column is not visible, open the View menu and select Markers. This allows you to focus on the problem
instead of the commands used to solve the problem. For example, when using the context-sensitive operations from
the Context Panel on Maple input in Document mode (invoked by moving your mouse cursor over your input expression,
then selecting the appropriate operation from the displayed context panel), input and output are connected using an
arrow or equal sign with self-documenting text indicating the calculation that had taken place. The command used to
solve this expression is hidden.

Ive - .
[l P4 Tx+ 10— (x= —2). {x= —35)

To create a new document, select File — New — Document Mode.

Worksheet Mode

Worksheet mode uses a Maple prompt as the default input region. The Maple input prompt is a red angle bracket, I}.
When using context-sensitive operations on input in Worksheet mode, all commands are displayed.

> so.fve(:cl +7x+10= [}}
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[> solve (x*2 + T*x + 10 = 0) ;
;

To create a new worksheet, select File — New — Worksheet Mode.

Full Flexibility in Either Mode

Regardless of which mode you begin working in, you have the opportunity to use both document blocks and command
prompts.

For example, you can hide commands in Worksheet Mode by adding a document block from the Edit menu, Edit —
Document Blocks — Create Document Block (see Document Blocks (page 35)), or you can show commands in
Document mode by adding a Maple prompt from the Insert menu, Insert — Execution Group — Before / After
Cursor (see Input Prompt (page 58)).

This chapter discusses features common to both modes. Specific aspects of Document mode are explained in Document
Mode (page 43), and aspects of Worksheet mode are explained in Worksheet Mode (page 57).

The Maple Workbook

The Maple Workbook acts as a container that lets you collect Maple worksheets, library archives and language files,
data (such as images or spreadsheets), and other items into a single file, stored in the .maple file format. This lets you
better organize your Maple-based projects. For more information, see Workbook Overview.

Navigation of Workbook files is accomplished through the workbook Navigator palette, available in the Workbook
tab. For more information, see The Workbook Navigator.

Entering 2-D Math

In documents, the default format for entering mathematical expressions is 2-D Math. This results in mathematical ex-
pressions that are equivalent to the quality of math found in textbooks. Entering 2-D Math in Maple is done using
common key strokes or palette items. For more information on palettes, see Palettes (page 15). An example of entering
an expression using common key strokes is presented in the following section. An example of entering an expression
using palette items is presented in Example 3 - Enter an Expression Using Palettes (page 20).

Common Operations

35

1
Entering mathematical expressions, such as 99 9, X+ X, and X-y is natural in 2-D Math.

To enter a fraction starting with the numerator:
1. Enter the numerator.

2. Press the forward slash (/) key.

3. Enter the denominator.

4. To leave the denominator, press the right arrow key.

To enter a fraction starting with the denominator:
1. Enter the denominator.

2. Press // (two forward slashes).

3. Enter the numerator.

4. To leave the numerator, press the right arrow key.
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To enter a power:

1. Enter the base.

2. Press the caret () key.

3. Enter the exponent, which displays in math as a superscript.

4. To leave the exponent, press the right arrow key.

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in 2-D Math as a dot, -.

3. Enter the second factor.
Implied Multiplication:

In general, the best practice is to enter a multiplication symbol (*) for multiplication in any calculation. In some cases,
you can instead insert a space character between two quantities to multiply them. This is called implicit multiplication.

-b++/ V¥ —4ac

For example, in the expression 2a a space is used for the multiplication 4*a*c and 2*a.

In the case of a number followed by a variable, Maple interprets the expression as meaning multiplication even without
the presence of * or a space character.

However, it's easier to identify and correct mistakes in your formulas if you use the multiplication symbol (*) regularly.

Important: Maple interprets a sequence of letters, for example, X), as a single variable. To specify the product of

two variables, you must insert a space character (or multiplication operator), for example, X y or x-y. For more inform-
ation, refer to the 2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

Symbol/Formats Key Example
implicit multiplication Space key (XZ —7xy+3 VZ) Xy
%
explicit multiplication ! Shift 2-3
fraction 2 / (forward slash) 1
/I (two forward slashes) 4
. hift +
exponent (superscript) 2 Shift X2
+ Shift + + Shift + i
indexed subscript2 Ctrl + Shift + _ (Command + Shift + _in X,
Mac)
literal subscript (subscripted __ (two underscores) X
max

variable name)

navigating expressions Arrow keys
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Symbol/Formats Key Example

. * Escin M i Li
command / symbol completlon3 sc in Mac, Windows, and Linux al

» Ctrl + Space in Windows

about (assumptions and properties)  abouf|expr |

+ Ctrl + Shift + Space in Linux

abreve &

abs 1x1
ahs ahz
abselsol (First order  DETools |abelsol || GDE, 3|
< >

square root sqrt and then command completion \/f

. . and then command completion
exponential function 2 «p p "
enter / exit 2-D Math * FS5key 1
» Math and Text icons in the toolbar 4 versus 1/4

! required for products of numbers

use the right arrow key to leave a denominator, numerator, superscript, or subscript region

3 for more information, see Command Completion (page 33).

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints help page. To access this help
page in the Maple software, in Math mode enter ?MathShortcuts and then press Enter. For information on the Maple
Help System, see The Maple Help System (page 36).

Example 1 - Enter and Evaluate an Expression Using Keystrokes
Review the following example:

X+y
2

Xy

In this example, you will enter 2 and evaluate the expression.

Action Result in Document
To enter the expression: A

1. Enter x.

2. Press Shift + ~ . The cursor moves to the superscript position. xj

3. Enter 2.

A

4. Press the right arrow key. The cursor moves right and out of the superscript position. ﬂ

5. Enter the + symbol.

= +|

6. Entery.

 +y
x2+yj

8. Enter 2 and press the right arrow key. 24 ﬂ

7. Press Shift + * to move to the superscript position.
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Action

Result in Document

9. With the mouse, select the expression that will be the numerator of the fraction.

.

10. Enter the / symbol. The cursor moves to the denominator, with the entire expression in
the numerator.

Tty
/

11. Enter 2.

4y
]

12. Press the right arrow key to move right and out of the denominator position.

21y

2
To evaluate the expression and display the result inline: X2 i )/2 xz )/2
13.Press Ctrl + = (Command + = in Mac). 2 = 2 + B3

To execute 2-D Math, you can use any of the following methods.

* Pressing Ctrl + = (Command + = in Mac). That is, press and hold the Ctrl (or
equal sign (=) key. This evaluates and displays results inline.

Command) key, and then press the

* Pressing the Enter key. This evaluates and displays results on the next line and centered.

 Select the input and from the context panel, select Evaluate and Display Inline. See The Context Panel (page 27)

for more details.

+ Using the Evaluate menu items Evaluate and Evaluate and Display Inline.
Toolbar Options
The Maple toolbar offers easy access to a number of actions. See Table 1.2.

Table 1.2: Maple Toolbar Options

Basic Usage

Equivalent Menu Option or
Command

Create a new Maple document

From the File menu, select New and
then Document Mode

Open an existing document or worksheet

From the File menu, select Open...

Save the active document or worksheet

From the File menu, select Save...

Print the active document or worksheet

From the File menu, select Print...

Print preview the active document or worksheet

From the File menu, select Print
Preview...

Cut the selection to the clipboard

From the Edit menu, select Cut

Copy the selection to the clipboard

From the Edit menu, select Copy

Paste the clipboard contents into the current document
or worksheet

From the Edit menu, select Paste

Undo the last operation

From the Edit menu, select Undo

Redo the last operation

NPl i | g o | e

From the Edit menu, select Redo
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Basic Usage

Equivalent Menu Option or
Command

Insert the Code Edit Region

From the Insert menu, select Code
Edit Region

Inserts plain text after the current execution group.

From the Insert menu, select Text.

Inserts Maple Input after the current execution group.
For details, refer to Execution Groups (page 13).

From the Insert menu, select
Execution Group and then After
Cursor

Encloses the selection in a document block. If nothing
is selected, it creates a new document block.

[N e

From the Edit menu, select Document
Blocks and then Create Document
Block

Encloses the selection in a subsection. For details,
refer to Sections (page 237).

v
N

From the Format menu, select Insert
Section

Remove one level of indentation enclosing the
selection.

From the Format menu, sclect Remove
Section

Move backward to previous document in the hyperlink
history

Open the start page

Move forward to next document in the hyperlink
history.

BR[|

Executes all commands in the worksheet or document

From the Execute menu, select
Execute Worksheet.

Executes a selected area.

From the Evaluate menu, select
Execute Selection.

Interrupt the current operation.

Debug the current operation

Clears Maple's internal memory. For details, refer to
the restart help page.

Enter restart.

Add and edit Maple code that is executed each time
the worksheet is opened. For details, refer to the
startupcode help page.

From the Edit menu, select Startup
Code.

Adjusts the display size of document content. Note:
Plots, images, and sketches remain unchanged.

From the View menu, select Zoom
Factor and then a zoom size.

Reset zoom level.

From the View menu, select Zoom
Factor — Default.

Opens the Maple help system in a new window. For
details, refer to The Maple Help System (page 36).

From the Help menu, select Maple
Help.

Search box provides quick access to the help system.

Access to the MapleCloud on the web.

The Context Bar shows icons that are relevant to the location of the cursor in the document. For example, place the
cursor at an input region and the Text and Math tools are accessible. See Table 1.3 for a list of the tools available in

each icon.
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Table 1.3: Context Bar Tools

Context Bar Tools

Text
‘Math | C Text T|| Times New Roman ~[[z~-] BT U EEZZ L g == &
Math
‘Text | C 2D Math "|| Times New Roman ~|[12 -] Bu == L g =iz &

Drawing tools

a5 «

EN BCYE

2-D Plot tools

B ~ 1 @Iy DPRAXQ b B «

3-D Plot tools

[Fet_~] O = |B¢@[ = HW[ o

Animation tools

|4 m p p|currentFrame |1 Ji P v A vres:| 10 ;| AR Q. e &

G- - 11 O AU QUL «

(1 ]

Table 1.4: Context Selector Options

Region Available Tools

Input region Text and Math icons

Plot region Drawing and Plot icons

Animation region Drawing, Plot, and Animation icons
Drawing Canvas and Image regions Drawing icon

The Text and Math icons allow you to enter text and math in the same line by choosing the appropriate input style at
each stage when entering the sentence.

sin(x) is cos(x)
For an example, see Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons (page 22).

The meaning of the Text and Math icons differs while at a Maple input prompt. The Math icon displays input as 2-D
Math, whereas the Text icon displays Maple input. For details, refer to Math Mode vs. Text Mode (page 14).

X
> 2
> xr2/2;

To access the tools available in the Plot and Drawing icons, click a plot region. These tools allow you to manipulate
the plot or draw shapes and enter text on the plot region. By clicking an animation region, you have the same features
available for a plot region, in addition to tools for playing the animation in the Animation icon. For details on plots
and animations, refer to Plots and Animations (page 191).

For the description of any icon, hover the mouse over the icon to display at tooltip.
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The Context Panel and Copy & Drag

Context Panel

Maple dynamically generates a collection of applicable options when you select or hover your mouse over an object,
expression, or region. The options are organized and collectively displayed in the context panel to the right-hand side
of the Maple user interface. The options available in the context panel depend on the selected input region. For example,
you can manipulate and graph expressions, enhance plots, format text, manage palettes, structure tables, and more.
When using menu items from the context panel to perform an action on an expression, the input and output are connected
with a self-documenting arrow or equal sign indicating the action that had taken place. For more information, see The
Context Panel (page 27).

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new input region. This is done by highlighting
the input or selecting the curve and dragging it with your mouse into a new input region. Dragging the highlighted region
will cut or delete the original input. To prevent this, use the copy and drag feature.

* Ctrl + drag, Windows and Linux

* Command + drag, Mac

That is, highlight the region you want to copy. Press and hold the Ctrl key while you drag the input to the new region
using the mouse. The analogous operation on Mac uses the Command key.

Example 2 - Solve and Plot an Equation Using Context Panel Options and Copy & Drag

Review the following example:
5x—7=3x+2

In this example, you will enter the equation and then solve and plot the equation using the context panel and the copy
& drag feature. This example will only refer to the keystrokes needed on a Windows operating system to invoke the
context panel and the copy & drag feature. For your operating system, refer to section Shortcut Keys by

Platform (page xiii) for the equivalent keystrokes.
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To solve the equation:
1. Enter the equation.

2. Click the equation and select Move to Left.

Input:
‘ Text | C 2D Math T||T|mesNewR.oman *|[12 ~] B: b
5x—T7=3x+2 - salve
or swap sides
X Jx+2
LAY
Plot both sides
5x—T7=3x+2
Evaluate and Display Inline
Explore
Map Command Onto
loretol 5
Result:

S5Xx—7=3x+2 movetoleft 5y g9_0

A brief description, "move to left" is displayed above the arrow that connects the input and output.

3. Right-click the output from the previous action, 2 x — 9 = 0, and select Solve — Isolate Expression for — x.
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Input:

Solve >]
Isolate Expression for k X
Mumerically Solve =

Mumerically Solve (w/complex) >

Mumerically Solve from point >
Obtain Selutions for L4
Solve

Solve (explicit)

Solve (general solution)

Solve for Variable 4

Result:

. x=2
5X—7=3X+2M2x—9:0 isolate for x >

Now that we have solved the equation, we can plot it. To do this, we will copy the equation 2 X — 9 = 0 to a new document block
and use the context panel again.

4. From the Edit menu, select Document Blocks— Create Document Block.

5. To copy the expression 5 X — 7 = 3 X + 2, highlight this expression from the previous line. Press and hold the Ctrl key and
drag the expression to the new document block region.

move to left isolate forx 9
—_— 2y — 9= x= el

move to left isolate forx
—_——

2x—9=0

-2
T3

3]

s x— 7=3x+2
L_ —T7=3x+
4]
B maove to left isolate forx

Sx—T7=3x+2—— 2x—5%=0

-2
=2

S5x—T=3x+2
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To plot the expression:

6. From the context panel, select Plot both sides.
Input:

Plot both sides

7

Result:
Plot both sides [5*x-7, 3*x+2]

5x—7=3x+2

40+

304

201

104

Saving a Maple Document

To save these examples you created, from the File menu, select Save. Maple documents are saved as .mw files.

Saving a Maple Document as a Workbook

To save these examples you created as part of a new Maple workbook, from the Workbook tab, click Save As
Workbook. For more information about saving Maple content see worksheet,managing,saving.

1.3 Entering Expressions

Execution Groups

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large
square bracket, called a group boundary, at the left. An execution group may also contain any or all of the following:
a plot, text, embedded components, and a drawing canvas.

Execution groups are the fundamental computation and documentation elements in the document. If you place the
cursor in an input command and press the Enter or Return key, Maple executes all of the input commands in the
current execution group.
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Math Mode vs. Text Mode

The default mode of entry in Document or Worksheet mode is Math Mode, which displays input in 2-D Math. In
Worksheet Mode or at a prompt, you can opt to use Maple Input (1-D Math). This is 1-D math input:

> simplify (cos (alpha)”*2+sin(alpha)*2);

> a*int (exp(sqrt(2) *x) ,x) ;

a2 e'? X

2

> limit(f(x) ,x=infinity);

lim_f(x)

X > ®

> sum(al[k]*x*k, k=0..m)=product(b[j]*x"],

j=0..n);

m n .
> akxkz [~
k=0 j=0"’

In Document Mode, to enter input using Maple Input mode, insert a Maple prompt by clicking » in the toolbar, and
then click the Text button in the context bar. In Worksheet Mode, simply click the Text button. See Figure 1.2.

Figure 1.2: Text and Math Buttons on the Toolbar

d

Table 1.5: Text Mode vs. Math Mode

Math Mode

Text Mode

Maple's default setting. Executable standard math notation.
This is also referred to as 2-D Math Input.

>Jx2+2x+1dx

1
§£+XZ+X

Executable Maple notation. This is referred to as 1-D Math
Input or Maple Input.

>int (x*2+2*x+1, x);

% P+ X+ x

Access from the Insert — 2-D Math menu.

Access from the Insert — Maple Input menu.

When using 2-D Math, the Math mode icon is highlighted in the

Text |[Makh

toolbar,

When entering Maple Input or text in a text region, the Text mode

Text|Makh

icon is highlighted in the toolbar,

In Document Mode (or a document block), input is entered in a

document block with a slanted cursor, ; |

L

In Document Mode (or a document block), text is entered with a

vertical cursor, as plain text, __, Enter some textj,

In Worksheet Mode, input is made at an input prompt with a

slanted cursor, I::’ L.

In Worksheet Mode, input is made at an input prompt with a

vertical cursor, [} | .

To convert a 2-D Math expression to 1-D Math, click the
expression, then from the context panel select 2-D Math —
Convert To — 1-D Math Input.

To convert a 1-D Math expression to 2-D Math, click the
expression, then from the context panel select Convert To —
2-D Math Input.
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Math Mode Text Mode
Palettes make entering expressions in familiar notation easier | Using palettes while in 1-D Math teaches you the related Maple
than entering foreign syntax and reduces the possibility of command syntax.
introducing typing errors.
W Expression
W Expression b

[ : > int(f,x);
Jrfdx'—_ﬁjcﬁ—_‘i’[fdx dex—H'-d:\———P_a [ £

2

If you prefer 1-D Math input in Worksheet mode, you can change the default math input notation.

To change math input notation for a session or globally across all documents:
1. From the Tools menu, select Options. The Options Dialog opens.

2. Click the Display tab.

3. In the Input Display drop-down list, select Maple Notation.

4. Click the Apply to Session or Apply Globally button.

This changes the default input math notation at the prompt (>).

Important: The new input display becomes the default setting after pressing the Enter key.

Palettes

Palettes are collections of related items that you can insert into a document by clicking or drag-and-dropping. The

Maple environment provides access to over 30 palettes containing items such as symbols (%), layouts (Ab), math-
b

dex

)
ematical operations [ a J and much more.

By default, palettes are displayed in the left pane of the Maple environment when you launch Maple. If the palettes
are not displayed,

1. From the View menu, select Palettes.
2. Select Expand Dock.

3. Right-click (Control-click, Mac) the palette dock. From the context menu, select Show Palette. Alternatively, from
the main menu, select View — Palettes — Show Palette.

A list of potential palettes is displayed, with currently displayed palettes dimmed.
4. Select a palette.

Alternatively, select View — Palettes — Show All Palettes.

You can create a Favorites palette of the expressions and entities you use often by right-clicking (Control-click, Mac)
the palette template you want to add and selecting Add To Favorites Palette from the context menu.
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Table 1.6: Palette Categories

Palette Category Palette Description
Alphabetical Palettes Greek B i

7 Greek Script A,

ABTAEZ Fraktur 2,

He I KAM Open Face C,
NZOTMPZX Cyrillic K,

TYY ® X ¥ Diacritical Marks = ,

Qop yd e Roman Extended Upper Case A,
e C n 9 9 1 Roman Extended Lower Case & .
K xt A pveEg

O wwpPpoa

§ TV Y

Wy oW

Mathematical Palettes Palettes for constructing expressions

Common Symbols,

Relational = S

W Common Symbols

Te i j I w
3! I d nu Relational Round = ,
S Operators =,
< 5§ 8 e Large Operators % s
e e Negated 7,
N@ IV - A Fenced {{ ,
Vyy=CRN Arrows %,
o Z R o= Constants and Symbols &0 .
F + —x J + Punctuation - insert punctuation symbols, such as inserting the registered trademark and
F o = V copyright symbols © into text regions
' X h 2 | Miscellaneous - insert miscellaneous math and other symbols outside the above categories

=]
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Palette Category

Palette Description

Expression Palettes

W Matrix
Rows: 2
Calumns: 2

| choose... |

Daka type; I':_#ny T'_

Insert Matrix

Shape; ":_ﬁmy Tt_'

Type: [ Custom values T\_"

. . . log, [«
Expression - construct expressions such as logarithms g(a) .

Matrix - enter the number of rows and columns required, designate type, such as zero-filled,
and designate shape, such as diagonal.

Layout - add math content that has specific layout, such as expressions with one or more

h
superscripts and subscripts

b
[re
Calculus - construct expressions such as integrals -z .
Units - select a unit and insert into document, such as [#] or %l .

o
Accents - insert decorated names, such as an X with an arrow over it to denote a vector A .

Trigonometric & Hyperbolic - a palette for constructing expressions containing
trigonometric and hyperbolic functions

Student Random Variables - a palette for constructing random variables based on
distributions in the Student Statistics package

Group Constructors - a palette for constructing groups based on the Group Theory package

Other Palettes

W Components

Bukton

jCombo Box -
[7] Check Box

@ Radio Butten

Text Area
Label
List Box

I
OMHE
>

I fix)dx

&€y |y

Components - embed graphical interface components such as a button into your document
or worksheet. Components can be programmed to perform an action when selected such as
executing a command when a button is clicked.

Favorites - add templates that you use most often from other palettes.Variables - manage
all of your assigned variables in your current Maple session.
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Palette Category

Palette Description

Task Palettes

¥ Live Data Plots

___
h
—=

Generate Area Chart
i L

1R

Live Data Plots - templates for visual representation of your data.

eBook Metadata - markup tags for use when creating eBooks from Maple worksheets

Tasks - a palette where you can store tasks that you have created

Viewing and Arranging Palettes

By default, palettes display in palette dock in the left pane of the Maple window. To view and manage palettes and

palette docks, see Table 1.7.

Table 1.7: Managing Palettes

To view the palette dock:

* From the View menu, select Palettes, and then Expand
Dock. The dock is in the left pant of the window.

SIS A<

Previcus Tab

Context Panel
Toolbar

Context Bar
Status Bar
Markers

Task Elements
Atomic Variables

Assignment
Slideshow F11

Workbook Mavigator
Palettes

Zoom Factor
Typesetting Rules...
Show/Hide Contents...

Back
Home

Forward

Sections

Insert Format Table Plot Tools Window Help

Mext Tab Ctrl+Tab
Ctrl+Shift+Tab

—
L

|7l
1
|l

&GS

n~][z~] B
s fors 9
e v =

2

L4 Arrange Palettes...

' Show Palette 4
Show All Palettes
Show Default Palettes

Expand All Palettes

Collapse All Palettes

Expand Dock L\\g‘
[ Collapse Dock
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To add a palette:

1. Right-click the palette dock. Maple displays a context
menu near the palette.

2. From the context menu, select Show Palette and then
select the palette.

[ Arrange Palettes...
Show Palette

Relational

Relational Round I}
Operators

Large Operators
MNegated

Fenced

Arrows

Constants and Symbols
Punctuation

Miscellanecus

Show All Palettes
Show Default Palettes

Expand All Palettes
Collapse All Palettes

Expand Dock

Collapse Dock

To expand or collapse a palette in the palette dock:

* Click the triangle at the left of the palette title.

= Favorites

P Units

P Expression

'}alculus

. oood
| —
x T:'af dx / d.12 /

fx) [ x)

A A

az az X
5
ax

X

x ¥
R

[[rava j j Jdrd
frose]

&£ &
dx”
) )

d .,
ox

o

ﬁ.rﬁ_r’r J,"dr J.-f'd'f

To move a palette in the palette dock:

* Move the palette by clicking the title and dragging the
palette to the new location.

- Favorites

> Expression

P Calculus

» gmor B Urits I

P Variables

P Matrin
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To expand or collapse the pane containing the palette
P P P g P Palettes | Warkbook

dock: 4 Text [Math
. . . . - Favorites | “\I ’
 Select the appropriate triangle at the top right side of the s
palette region. P Linits |
W Expression

a+h a—bh a+b -

Example 3 - Enter an Expression Using Palettes

Review the following example:

10
S(7£-51)
i=1 = 2420
10
S(72=51)
In this example, we will enter i=0 and evaluate the expression.
Action Result in Document

1. Place the cursor in a new document block. In the Expression palette,

i
” )
>.f 2.
click the summation template =% . Maple inserts the summation i=k
symbol with the range variable placeholder highlighted.

2. Enter i and then press Tab. The left endpoint placeholder is selected. 1
Notice that the color of the range placeholder has changed to black.
Each placeholder must have an assigned value before you execute the ZI
expression. The Tab key advances you through the placeholders of an|i = jg
inserted palette item.

3. Enter 1 and then press Tab. The right endpoint placeholder is selected.

4. Enter 10 and then press Tab. The expression placeholder is selected. | 10

5. Enter ( 72 -5 i). For instructions on entering this type of expression, 10
see Example I - Enter and Evaluate an Expression Using E ( 7 2z 5 I)
Keystrokes (page 6).

6. Press Ctrl + = (Command + = for Mac) to evaluate the summation. 10

Favorites Palette

You can add to the Favorites palette any expressions that you use most often.

» To add an entry from another palette to the Favorites palette, simply drag the entry to the Favorites palette.
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» To add a custom expression, select the expression in the worksheet and select Add Selection to Favorites Palette
from the Context Panel.

Symbol Names
Each symbol has a name and some have aliases. By entering its name (or an alias) in Math mode, you can insert the
symbol in your document. All common mathematical symbols, including all Greek characters, 7, and the square root

symbol (\/_ ), are recognized by Maple.
Note: If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.

To insert a symbol, enter the first few characters of a symbol name using a keyword that is familiar to you and then
press the completion shortcut key, Esc (see Shortcut Keys by Platform (page xiii)). Symbol completion works in the
same way as command completion (see Command Completion (page 33)).

 If a unique symbol name matches the characters entered, Maple inserts the corresponding symbol.

* If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches,
including commands. To select an item, click its name or symbol.

Example 4 - Square Root

To find the square root of 603729:

Action Result in Document

1. In a new document block, enter sgrt. S_qd

2. Press the symbol completion shortcut key, Esc. Maple
displays a popup list of exact matches.

3. In the completion list, select . JE

Maple inserts the symbol with the X placeholder selected.

4. Enter 603729 into the placeholder. /603729
5. Press Ctrl + = (Command + =, Mac). 603729 = 777

Example 5 - Complex Numbers

In Maple, the default display for imaginary i is a capital . When you simply type the letter i in Math mode, it is in

italics. This letter is just a variable, and is not the same as the imaginary unit -1, denoted by I or i in Maple.
sum(i,i=1.4) =10
Multiply two complex numbers, -0.123 + 0.7451 and 4.2 —1i:

We will compute the result two ways, using I and then using i. The first way is the quickest to enter.
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Table 1.8: Complex Numbers using I

Action Result in Document

1. In a new document block, enter (-0.123 + 0.7451)-(4.2 — 1)
(-0.123 +0.7451)-(4.2 — 1)

Use * to enter multiplication between the two
complex numbers.

2. Press Ctrl +=(Command + =, Mac) to evaluate| (_(.123 + 0.7451)-(4.2 —I) = 0.2284 + 3.25201
the product.

The next method, while not as quick to enter, displays the computation using lowercase i.

Table 1.9: Complex Numbers using i

Action Result in Document

1. In a new document block, enter (-0.123 + 0.745 3
(-0.123 +0.745 i.

2. Press the symbol completion shortcut key, Esc. (=0.123 + 0.745 §f

Maple displays a popup list of partial and exact [P

matches, including symbols and commands. iacute il
ic ic
icirc i
iconkent Teonfant(p )
iconkent inontent
icosahedron (location) ploffools [Teosahedron ][ [x, 0, £])
icosahedron (location, scale)  ploffools[icosahedron i [x,p, 2L n) ¥
£ | 1 | =3

3. Select the imaginary unit, [{{E=24) (-0.123 + 0745

4. Close the parentheses, enter * (for multiplication), (-0.123 + 0.7451)-(4.2 —1)
and type the second expression in parentheses,
using symbol completion for the second imaginary
number.

5. Press Ctrl + = (Command + =, Mac) to evaluate| (-().123 + 0.7451)-(4.2 —i) = 0.2284 + 3.25201
the product.

For more information on entering complex numbers, refer to the HowDol/Enter AComplexNumber help page.

Toolbar Icons

In the introduction section, you learned about the toolbar icons and context toolbars available in Maple (see Toolbar
Options (page 7)). The toolbar can be used to format your document, alter plots and animations, draw in a canvas,
write in both Math and Text modes in one line and much more. The last of these is demonstrated in the next example.

Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons
Enter the following sentence:
Evaluate

5
j(3x2+zﬁ+33J?)dx
1

and write in simplest terms.
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Action Result in Document

Text]math | C Text

| Evaluate |

To enter this sentence:

1. Select the Text icon and enter "Evaluate ".

2. Select the Nonexecutable Math icon.

3. From the Calculus palette, select the definite integration fest |Math| | C Text

X 1

X 3
[ dx
: o . Evaluate | fdx
template, . The expression is displayed with the
first placeholder highlighted. m

| I

4. With the first placeholder highlighted, enter 1, then press [~ 3
Tab. Evaluate J [3)62 + 2|dx
1

5. Enter 5 and press Tab to highlight the integrand region. |-

6. Enter (3x”2 and press the right arrow to leave the
superscript position.

7. Enter + 2.

8. Press the Space bar for implicit multiplication. Enter sqrt
and press Esc to show the command completion options. Evaluate [3 i + 2 sqrtdy

Maple displays a popup list of exact matches. Select the

sqrt sori
1 2

square root symbol, \/7 .

Maple inserts the symbol with the x placeholder selected.
(Alternatively, select the square root symbol from the
Expression palette.)

9. Enter x, then press the right arrow to leave the square root

region. Evaluate

Jj
1
h] 5 a
J[3f+zﬁ+3ﬁdx
1

10. Enter + 3, and then press the Space bar.

11. Select the n-th reot symbol from the Expression palette,

Va .

12. Enter 3, then press Tab. 5 5
13. Enter x, then press the right arrow to leave the root region. Evaluate J. [ 3 x}l +2 v{; +3 v{; dx
14. Enter ), then press Tab. .

15. Enter x for the integration variable.

16. Put the cursor after the expression and click the Text icon M " | C Tex - | [Times New o 2~
. [=kd El [= Imes New T an i &~
in the toolbar, then enter the rest of the sentence: " and
write in simplest terms." 2 3

Evaluate J 3P +2 Jx + 33 x dx and write in simplest terms.
e 1

Note: When an expression is intended for display purposes only, as in this example, it can be displayed in nonexecutable
math. This is indicated by the gray background. For more information on executable and nonexecutable math, see
2DMathDetails.
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1.4 Point-and-Click Interaction

Maple contains many built-in features that allow you to solve problems quickly without having to know any commands.

Assistants

Maple offers a set of assistants in the form of graphical user interfaces to perform many tasks without the need to use
any syntax.

Using the Tools — Assistants menu, you can access tools to help you accomplish various tasks. See Figure 1.3. In
some cases, you can launch an assistant by entering an expression and selecting the assistant from the options in the
Context Panel.

Tools | Window Help

Assistants } Code Generation...
Math Apps [:f‘ Data Set Search...
Tutors } eBook Publisher...
Tasks ¥ Import Data...
MapleCloud Installer Builder...
Load Package y| Library Browser...
Unload Package | Maplet Builder...
Spellcheck... F7 EI‘_]t Bl_.u.lder...
Complete Command ctri+Shift-Space §<:|er:t|f|c Con.stants...
Help Database N Special Eunc.tlons... .
- Thermophysical Properties Calculator...
ST Units Converter...
Worksheet Migration...

Figure 1.3: Accessing the Assistants from the Tools Menu

Descriptions of Assistants

The available assistants are described below. Some of the assistants are interfaces to package commands. For more
information on package commands, see Package Commands (page 32).

CAD Link - an interface to explore the properties of models from supported CAD applications (available on Microsoft
Windows only).

Code Generation - an interface to automatically transform Maple expressions and programs to other languages.
Data Set Search - an interface for searching built-in and online data sources.

eBook Publisher - an interface to the eBook Publisher tools.

Import Data - an interface to read data from an external file into Maple.

Installer Builder - an interface to the InstallerBuilder package in which you can create installers for your Maple
toolboxes.

Library Browser - an interface to manipulate the libraries in a specified directory.

Maplet Builder - an interface to the Maplets package. The Maplets package contains commands for creating and
displaying Maplet applications (point-and-click interfaces). Using the Maplet Builder, you can define the layout of
a Maplet, drag-and-drop elements (visual and functional components of Maplets), set actions associated with elements,
and directly run a Maplet application. The Maplet Builder is available in the Standard interface only.

Plot Builder - an interface for creating two and three-dimensional plots, animations, and interactive plots.

Scientific Constants - an interface to over 20 000 values of physical constants and properties of chemical elements.
All of these constants come with the corresponding unit and, if applicable, with the uncertainty or error, that is, how
precisely the value of this constant is known.
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* Special Functions - an interface to the properties of over 200 special functions, including the Hypergeometric,
Bessel, Mathieu, Heun and Legendre families of functions.

* Thermophysical Properties Calculator - Calculate state-dependent and independent thermophysical properties.
» Units Converter - an interface to convert between 500 units of measurement.

* Worksheet Migration - an interface to convert worksheets from Classic Maple (.mws files) to Standard Maple
(.mw files).

Tutors

Maple provides over 50 interactive tutors and assistants to aid in the learning of
* Basics

* Precalculus

* Calculus

* Multivariate Calculus
* Vector Calculus

* Complex Variables

+ Differential Equations
* Linear Algebra

* Numerical Analysis

» Optimization

* Statistics

These tutors are easily accessible in the Tools menu by selecting Tutors. See Figure 1.4.

Tools | Window Help

aTTEE e PRA S &2 @ [search Alt+g]
Math Apps
Tutors } Basics ]
Tasks ¢ Precalculus b
MapleCloud Calculus - Single Variable »
Load Package p| Calculus - Multivariate ]
Unload Package p| Vector Calculus
Spelicheck... F7 Cf]mple; ?J'Elrlahles.
Differential Equations

Complete Command ctrl+5hift-Space
Help Database

Numerical Analysis Eigenvalues...
Optimization Eigenvectors...

Statistics Gauss-lordan Elimination...
Gaussian Elimination...
Linear System Plot...
Linear System Solving...
Linear Transform Plot...
Matrix Builder...

Matrix Inverse...

Options...

]
]
]
n Linear Algebra » Eigenvector Plot...
]
]
]

Figure 1.4: Accessing Tutors from the Tools Menu
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Some of the tutors can also be accessed through the Student package. The Differential Equations tutor, DE Plets, is
accessible through the DEtools package. For a definition of the term package, see Package Commands (page 32).

The Student package is a collection of subpackages designed to assist with the teaching and learning of standard un-
dergraduate mathematics. The subpackages contain many commands for displaying functions, computations, and the-

orems in various ways, and include support for stepping through important computations.

The interactive commands help you explore concepts and solve problems using a point-and-click interface. These
commands launch tutors that provide a graphical interface to some of the visualization and computation commands

described above. See Figure 1.5 for an example of one of the tutors.

-

W& Calculus 1 - Differentiation Metheds
File Edit Rule Definition Apply Rule Understood Rules Help
Enter a function

Function | 2% +cos(x)fsin(x)

Variable x

&3

)
)
)
]
)

i[ [? CQS(IJ ]] The sin rule has been
dx sin(x) applied.
= l(?r) + d [ coslx)
de de | sin(x)
SIERPEE-)
T dx dx | sin(x) [#] Show Hints
4 [ coslx)
de | sin(x)
d ) d .
Eco.s(_r) sinlx) - cos(x) E:m(_‘c)
.SE'FI:_‘( [ Constant ][ Identity ]
;
—sz'ril:c—cos(:c) [—sz'n(_r]] onstant Muitiple
=7 4 . dx [ Sum ][ Difference
N fmﬁx l Product ” Quotient
=24 M [ Pawer ][ Chain Rule
SITX l Integral ][ Rewrite
l Exponential ” Natural Logarithm
:<trig> - <hyperbolic > -
:<arctrig:> - <archyperbolic> w
[ Undo ] [ Mext Step ] [ All Steps ] [ Close ]

Figure 1.5: Calculus - Single Variable — Differentiation Methods Tutor

The Practice Sheets Assistant, found under Tools — Tutors— Basics, lets you construct a practice sheet of math
problems. It's easy to interactively construct a randomized set of problems arithmetic, algebra, calculus, factorization
and more. Students can then do the problems, check their solutions, and even generate another set of problems.

For more information on the tutors and related resources for mathematics education, see Teaching and Learning with

Maple (page 148).

Math Apps

Maple provides Math Apps that offer interactive, entertaining ways to explore mathematical concepts, ranging from
Precalculus to Physics to Economics. A guide to these demonstrations is accessible in the Tools menu by selecting

Math Apps.
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The Context Panel

The context panel is a dynamically generated list of tools and actions that are applicable for the region on which it is
invoked. These tools and actions are further organized into menus. Use the context panel to perform calculations and
manipulations on expressions without using Maple syntax. To display the context panel, select an object, expression,
or region. Context panel options are available for many input regions, including:

* expressions to perform calculations, manipulations, or plotting

* plot regions to apply plot options and manipulate the plot

* tables to modify the table properties

* text regions to add annotations and format text

When performing calculations or manipulations on an expression, a self-documenting arrow or equal sign connects

the input and output, indicating the action that took place. See Figures 1.8 and 1.9 for two examples of context-sensitive
operations.

L'--:\ll —L "I‘_:' B 3 Pt
3 Lire
Paint
Paint and Line
¥ Surface with Line
Suface
Surface with Conteur
Contour
Apply a Command Tiia Hiden
Assign to s Name

Cosficanty

Manipulatce
Expart
Collect Scaling Canstrained
Ditterentate
Evalute ot a Point

Expand

Facter

Integrate

e Figure 1.7: Click the plot to see plot options in the context
Piots panel

Geenay

Sanplily

Sohe

Isolste Expresoion for L}
Musmnencally Sodee

Husmencally Sebee (o comple)
Musmnamcally Seba froen point
Oktmn Saluicen for

Sobee

Sobve (eplict]

Soive (general soluben)

Sebee for Wanable

Figure 1.6: Click the expression to see applicable operations
in the context panel

Task Templates

Task templates help you perform specific tasks in Maple, such as:

* performing a mathematical computation such as solving an equation symbolically or numerically, or determining
the Taylor approximation of a function of one variable

* constructing a Maple object such as a function

* creating a document such as an application

Each task contains a description along with a collection of content that you can insert directly into your document.
Content consists of 2-D mathematics, commands, embedded components (for example, buttons), and plots. You specify
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the parameters of your problem and then execute the commands in the document. See Figure 1.8 for an example of a
Task Template.

-

@ Browse Tasks =ENEE

File View

, Connectivity
= | Tasks
Qwerview [] Insert into Mew Worksheet || Display task markers
[#- . Algebra
[ |, Calculus - Differential kal
= Caleus - Integral V¥ Approximate Definite Integral of a Function
. Integration
EI . Approximate Integration

¥ Description

4
[ Copy Task to Clipboard l [ Insert Default Content ] [ Insert Minimal Content ]
K

m

MNumeric Integration . o . . . .
Approximate the definite integral of a univariate function using a

, Methods of Integration 1
Applications Riemann sum or a Newton-Cotes method.
[+ ) Series 4
- || Caleulus - Multivariate Enter the function as an expression.

[ . Calculus - Vector

Convert Expression to Function 2 .
[ || Curve Fitting > i+l .
[ |, Differential Equations ¥ +2 (1)
B | Document Templates Specify the range of integration and the method of approximation, and then
[ [ Evaluating approximate the integral
[# | Geometry
[#- | Integers ;
i || Linear Algebra > Stucent| Calculus 1] Approximatelnt|((1), x=0 .. 7t method
B b Lists = trapezoid)
G- | Flots 1 2
[ |, Paolynomials 200 T (6? T 400) 2)
-l Statistics > Student| Calculus 1] Approximatelnt|( (1), x=0 . m method = trapezoid
[#- |, Transformations : -
[#- | Units, Constants, and Errors prw:pfor}
[#- |, eBook Metadata
i mn | ] 3

Task,ApproxDefIntegralUnivariateFcn

Figure 1.8: Browse Tasks Dialog

Previewing Tasks

To preview Maple tasks,

* From the Tools menu, select Tasks, and then Browse. The Browse Tasks dialog opens and displays the list of tasks.

The tasks are sorted by subject to help you quickly find the desired task. In the Browse Tasks dialog, you can view
tasks without inserting them into your document.

Inserting a Task into the Document

To insert a task into your document,
1. Select the Insert into New Worksheet check box to insert the task into a new document.
2. Click one of the insert buttons.

* Click the Insert Default Content button. Maple inserts the default content. The default content level is set using
the Options dialog. For instructions, see the usingtasks help page.

¢ Click the Insert Minimal Content button. Maple inserts only the commands and embedded components, for example,
a button to launch the related assistant or tutor.
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* Click the Copy Task to Clipboard button. Place the cursor where you want to insert the task, and then paste the
task. Maple inserts the default content. Use this method to quickly insert a task multiple times.

Note: You can view the history of previously inserted tasks. From the Tools menu, select Tasks. Previously selected
task names are displayed below the Browse menu item.

Before inserting a task, Maple checks whether the task variables have assigned values in your document. If any task
variable is assigned, the Task Variables dialog opens to allow you to modify the names. Maple uses the edited variable
names for all variable instances in the inserted task.

By default, the Task Variables dialog is displayed only if there is a naming conflict. You can set it to display every
time you insert a task.

To specify that the Task Variables dialog be displayed every time you insert a task:
1. From the Tools menu, select Options.

2. Click the Display tab.

3. In the Show task variables on insert drop-down list, select Always.

4. Click Apply to Session or Apply Globally, as necessary.

Updating Parameters and Executing the Commands

In inserted Task Templates, parameters are marked as placeholders (in purple text) or specified using sliders or other
embedded components.

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the
next placeholder by pressing Tab.

2. Execute all commands in the task by:

Placing the cursor in the first task command, and then pressing Enter repeatedly to execute each command.

Selecting all the template commands, and then clicking the execute toolbar icon [ .

W

. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the tasks help page.

Exploration Assistant

The Exploration Assistant allows you to interactively make parameter changes to expressions and view the result. The
assistant can be used with almost any Maple expression or command that has at least one variable or parameter.

To launch the Exploration Assistant:
1. Enter an expression or command.
2. Click the expression or command. From the context panel, select Explore.

3. The Explore parameter selection dialog appears, where you can select the parameters to explore and the range for
each parameter.

If you enter integer ranges, only integer values are allowed for parameters. To allow floating-point values, enter floating-
point ranges.

Select skip for any of the parameters to leave that parameter as a variable.

4. Click Explore to continue to the Exploration Assistant. The assistant creates a table in the document. You can use
the slider or sliders to vary the parameters and see your changes as the expression output is updated.

5. Once you are finished interacting with the assistant, you can copy and paste the results into your document, or save
the interactive document for later use.
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Example 7 - Use the Exploration Assistant to Explore a Plot

sin(a x) — bcos(x)

In this example, we will explore how the plot of X changes as we vary the parameters a and b.
Action Result in Document
1. Enter the plot command shown. sin(a x) — bcos(x)
plot ,x=1.10
X
2. Click the expression and select Explore Pﬂ,m[ sin(ax) — beosfx) __, ..||}:| ][ sinfax) —beos(x) . o
from the context panel. \ x ' L | . : B
Evaluate and Display Inline
Apply 8 Command
Assign to a Mame
Evaluate
3. Inthe Explore parameter selection dialog, |/ E—
* Explore | 3 |
set the ranges a = 0..10.0 and b = -5..5.0. —
Parameter Controls
Basics Overrides
skip control values placement animate
B a :slider - 0 10.0 :default v: :default v:
[ b |sider N 5.0 default v | [default v |
Misc.
Defaults size default
. . loop never w |
placement |unset r .
= = frames 50
animate unset =
: ! numeric ]
echoexpression
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Action

Result in Document

4. Click Explore. The Exploration Assistant
creates a table in the document. Move the
sliders to see the plot as the parameters
change.

Tip: Since decimal numbers were used for
the ranges in step 3, the slider uses decimal
numbers. If you use integers for the ranges,
the slider uses integer numbers.

0.0 3.33 6.67 10.0

-5.0 -1.67 1.67 5.0

1.5 Commands

Even though Maple comes with many features to solve problems and manipulate results without entering any commands,
you may find that you prefer greater control and flexibility by using the set of commands and programming language

that Maple offers.

The Maple Library

Commands are contained in the Maple library, which is divided into two groups: the main library and packages.

The main library contains the most frequently used Maple commands.

Packages contain related commands for performing tasks from disciplines such as Student Calculus, Statistics, or

Differential Geometry. For example, the Optimization package contains commands for numerically solving optimiz-

ation problems.

For details on top-level and package commands, see Commands (page 59).
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Entering Commands

If you want to interact with Maple using commands, simply enter the command using 2-D math. Notice that commands
and variable names display in italics. Maple commands are constructed in a format similar to command(arguments),
based on the command you are using.

For example, to factor an expression, enter:

factor(x2 +2x+ 1)

(x+1)°

To differentiate an expression, enter:

diff(sin(x), x)

cos(x)
To integrate an expression on the interval [0, 2 7], enter:

int(2 x+ cos(x),x=0.2n)

To plot an expression, enter:
plot(sin(x) xz x=-10 ..10)

60
40 =

20 =

For a list of the top commands in Maple, see Top Commands (page 61).

Package Commands

There are two ways to access commands within a package, using the long form of the package command or the short
form.
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Long Form of Accessing Package Commands:

The long form specifies both the package and command names using the syntax package|command](arguments).
LinearAlgebral RandomMatrix](2)

44 -31
92 67

Short Form of Accessing Package Commands:

The short form makes all of the commands in the package available using the with command, with(package). If you
are using a number of commands in a package, loading the entire package is recommended. When you execute the
with command, a list of all commands in the package displays. To suppress the display of all command names, end
the with(package) command with a colon. Alternatively, you can load packages through the Tools menu, by selecting
Load Package, and then the package name.
with( Optimization)

[ ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]

After loading a package, you can use the short-form names, that is, the command names, without the package name.

LSSolve([x—2,x—6,x—9])
[12.3333333333333321, [x=5.66666666666667] |

For a list of the top packages in Maple, see Top Packages (page 62).

Command Completion

To help with syntax and reduce the amount of typing when entering Maple commands, you can use command completion.
Command completion displays a list of all Maple packages, commands, and functions that match the entered text. If
there are multiple ways to call a command, then the command completion list contains each one, with appropriate
placeholders.

To use command completion:
1. Begin entering a command or package name.

2. Select Tools — Complete Command or use the shortcut key Esc (see Shortcut Keys by Platform (page xiii)). If
there is a unique completion, it is inserted. Otherwise, a list of possible matches is displayed.

3. Select the correct completion from the list.

Linear

Linearalgebra 2 [l
LinearalgebralAdd] (linear combinatian) LinearAlgebra| Add |( Mo ], Mv2)
LineatalgebralAdd] (inear combination, with scalars and constructar opkions) LinearAlgebra | Add (v, v2, xI, x2
Linearalgebraladd] {inear combination, with scalars) LinearAlgabra | Add | Mel, Me2, x1, x3)
Linearalgebraladd] {inear combination, with scalars, construckor options, and overnwrite) Lineay Algabra [Add (v
LinearAlgebralAdjoint] {square Matrix) Iinaar Alpabra [ Adiaing 1 1)
LinearAlgebralAdjoint] {square Matrix, with constructor options) Lineay Algabra [ Adicinf || M, ougpuforsions = Baf'
LinearAlgebra[Backwardsubstituke] (upper rov-echelon) Lineay Algabra | BackwardSubsifute 10 )
LinearAlgebra[Backwardsubstituke] (upper rov-echelon) Linaay Algabra | BaciwardSubsifute || M, b
LinearAlgebra[Backwardsubstituke] (upper rov-echelon, with options and overwrite) IrnearAlgabra | BackhwaerdSy
LinearalgebralBackwardSubstitute] {upper row-echelon, with options) LinearAlgebra|BackwardSubstitute || M, v,
!i{nﬁar.ﬂlnﬁhral’ﬁandl\ﬂarriﬂ (Fram aralarst Timaardicahval Randifapir 1 ivi v _\}l_ ]
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4. Some inserted commands have placeholders, denoted by purple text. The first placeholder is highlighted after you
insert it into the document. Replace it with your parameter, then move to the next placeholder by pressing the Tab
key.

Equation Labels
Equation labels help to save time entering expressions by referencing Maple output. See Figure 1.9.

By default, equation labels are displayed. If equation labels are not displayed,

1. From the Tools menu, select Options, and click the Display tab. Ensure that the Show equation labels check box
is selected.

2. From the Format menu, select Equation Labels. Ensure that both Execution Group and Worksheet are selected.

|51'r1(:c) dx
- -cos(x) (1)
|(1) dx

-sin(x) )
Figure 1.9: Equation Label

To apply equation labels:

1. Enter an expression and press Enter. Note that the equation label is displayed to the right of the answer in the doc-
ument.

2. In a new execution group, enter another expression that will reference the output of the previous execution group.

3. From the Insert menu, select Label. Alternatively, press Ctrl+L (Command+L, for Mac) to open the Insert Label
dialog. Enter the label number in the Insert Label dialog and click OK. The item is now a label. See Figure 1.10.

e

‘sin(x) dx

| | ’[‘H‘ d:l-
— Insert Label @

Type: Equation -

-cos( x) (L

Identifier: |1

oK ] | Cancel

Figure 1.10: Inserting an Equation Label

4. Press Enter to obtain the result.

To change the format of equation labels:

* Select Format — Equation Labels — Label Display. In the Format Labels dialog, select one of the numbering
schemes. Numbering can be flat numbers for the entire worksheet, or by section, so that equations in section 1 are
labeled (1.1), (1.2), and so on.

» Optionally, enter an appropriate numbering prefix.
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Format Labels @

Label Numbering Prefix ||

Label Mumbering Scheme | Sections Mumeric -

[ OK ] | Cancel

Figure 1.11: Controlling Equation Label Format

The Label Reference menu item allows you to switch between the label name and its reference content. Place the
cursor on the referenced equation label and select Format — Equation Labels — Label Reference.

sin(x) dx

-cos(x) (n

—cos(x) dx

—sinfx) (2
Figure 1.12: Label Reference

The label is associated with the last output within an execution group.

You cannot apply equation labels to the following:
* Error, warning, and information messages

» Tables, images, plots, or sketches

Document Blocks

In Document mode, content is created as a series of document blocks. Document blocks allow you to hide the syntax
used to perform calculations, which in turn lets you focus on the concept presented instead of the command used to
manipulate or solve the problem. You can also create document blocks in Worksheet mode to perform the same function.
Document blocks are typically collapsed to hide the Maple code, but these regions can also be expanded to reveal this
code.

To create a document block:

From the Edit menu, select Document Blocks — Create Document Block. If text or math in one or more execution
groups is selected, then a document block is created that contains those execution groups. If not, a new document block
is created after the current execution group. For more information, see the next example.

Document block regions are identified using markers that are located in a vertical bar along the left pane of the document.
See Figure 1.13. In addition to document block boundaries, these markers (icons) indicate the presence of hidden at-
tributes in the document such as annotations, bookmarks, and numeric formatting.

To activate markers:

From the View menu, select Markers. See Figure 1.13.

4 1oxi ] [ C 0 mah > | [Tin

2 4 10x+21 22 (x 4 7) (x+3)

Figure 1.13: Document Block Markers
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To view code in a document block:
1. Place the cursor in a document block to be expanded.

2. From the Edit—Document Blocks menu, select Show Command.

2+ 10x+21

@+ 10x+ 21 (L)
factor

(x+T7)(x+3) (2)

Figure 1.14: Expanded Document Block

With the Document Block expanded, you can see the Maple command that was used to perform this calculation. In
Figure 1.14, the so/ve command was used.

Also notice a red prompt (>) before the original expression and the so/ve command. Entering commands outside of a
document block region is done at this input region. To insert an input region, click the > button in the toolbar menu.

In Figure 1.14, an equation label was used to refer to the expression. For more information, see Equation
Labels (page 34).

To collapse a Document Block:

» With your cursor inside the document block, from the Edit — Document Blocks menu, clear the check box for
Show Command.

You can use this process of expanding document blocks to view and edit Maple commands within a document block.
Changing the Display:

You can specify which parts of the input and output are displayed when the document block is collapsed. For each
execution group in the block, you can choose to display either the input or the output.

* Place the cursor in the execution group.

* From the Edit — Document Blocks menu, select Toggle Input/Output Display.

Also, you can choose to display output either inline or centered on a new line.

* From the Edit — Document Blocks menu, sclect Inline Document Output.

1.6 The Maple Help System

The Maple program provides a custom help system consisting of almost 5000 reference pages. The help system is a
convenient resource for determining the syntax of Maple commands and for learning about Maple features.

Accessing the Help System

There are several ways to access the Maple help system:
* From the Help menu, select Maple Help.
» Enter a search term in the search box in the worksheet toolbar.

* Click (?) in the toolbar.
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To get help on a specific word:

* In a document, place the insertion point in a word for which you want to obtain help. From the Help menu, select
Help on .... Alternatively, press F2 (Control + ?, for Mac) to access context-sensitive help.

* In a document, execute the command ?topic, for example, enter ?LinearAlgebra and press Enter.

The Maple help system opens in a separate window with two panes. The left pane contains the Help Navigator where
you initiate searches and browse the table of contents, and the right pane displays the final search result, such as a

specific help page.
(8§ Maple 2019 Help - [fsolve] o |[= ==
File Edit View History Help
g ¢ m
SEN) E
» fsolve
Products: = 1 ‘ . " f . :
rodue Maple,User Help,Global Optimization ... ~ | | splve one or more equations using floating-point arithmetic
Page Types: | application,Assistant, Dictionary,Exa...
Table of Contents | R
3012 of Contents | Search Reaults Calling Seguence Examples
~ |, Getting Started o )
VWhat's New and Release Notes ] Parameters Details
. Create Maple Worksheets Basic Information
. Create Maple Workbooks -
- | Share Maple Content
Connectivity
=~ | Mathematics H
General Information Calllng Sequence See Also
Algebra fsolve( equations, variables, complex )
Basic Mathematics Diaits
Caleulus —
Calculus of Variations dsolve/numeric =
P Parameters : =
Differential Equations Numerc
Cifferential-algebraic Equations equations - equation. setlequation), expression, set(expression), list(equation), Computationin
DifferentialGeometry procedure, list(procedure) Maple
Discrete Mathematics dsolve/numeric
Evaluation ) ) variables - (optional) name or set(name); unknowns for which to solve -
=+ | Factorization and Selving Equations RootFinding
I . N . .
O rimcls complex - (optional) literal name; search for complex solutions Analytic
LeastSauares RootFinding
LinearFunctionalSystems L . . Isolate
LinearOperstors 1 Basic Information v
inearSolve ——

MinimalPolynomial
Numerical Solutions
RootFinding
dsolve/DAE
dsolve/dverk7a
i dsolve/numeric
fsolve

Detailed Information
? | salveffloat
QDifferenceEquations

RegularChains
Roots
SolveTools
Symbolic Solutions
hermite pade
{7 invfunc
2 isolate
minimia
msolve
powsolve
{7 | rsalve
{7 singular
Finance
Fractals
FunctionAdvisor
Geometry
Group Theory
Inert Functions
Iterative Maps
Linear Algebra
Logic
Mathematical Functions
Number Theory
Numbers

Description

+ The fsolve command numerically computes the zeroes of one or more equations,
expressions or procedures.

Output
» The solutions to a single equation are returned as an expression sequence.
» The solutions to a set orlist of equations are returned as sets of equation sequences.

« For a single polynomial equation of one variable with real coefficients, by default the
fsolve command computes all real {(non-complex) roots. It may not return all roots for
exceptionally ill-conditioned polynomials.

+ For a single polynomial equation of one variable with some (non-real) complex
coefficients, the fsolve command computes all real and complex roots. It may not
return all roots for exceptionally ill-conditioned polynomials.

+ For a general equation or system of equations, the fsolve command computes a
single real root.

Examples

A Polynomial Equation in One Variable

For a univariate real polynomial equation, the fsolve command computes all real
solutions.

> pohmomial = 220 — 11 =78 + 122 —4x=0

> faolvel polynomial)
—1.334383488, 0., 5.925222024 (03]

Figure 1.15: Sample Help Page

Every help page in Maple lists the command's calling sequence, parameters, and a description, with examples of the
command at the end of the page. Some help pages also contain hyperlinks to related help pages and hyperlinks to dic-
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tionary definitions. Hyperlinks to dictionary definitions display in red to distinguish them from hyperlinks to help
pages.

Using the Help Navigator

Use the search field in the Help Navigator to find information on Maple commands and features.
* Search for a known help topic, a command name, or a keyword or phrase.

 If you have any add-on products, you can restrict the search to Maple, MapleSim, or any combination of those
products and their add-ons.

* You can search all of the help system or specific Resources such as Help Pages, Tasks, Math Apps, and Manuals
by selecting the Page Types drop-down menu.

Search results are displayed as a list in the Search Results tab of the left pane. Click the Table of Contents tab to
view a structured list of all topics in the help system.

Note that some tutorials open in a Maple window instead of in the Help window.
In the left pane, the type of resource is indicated by an icon. Table 1.10 describes the icons.

Table 1.10: Help Page Icons

Icon Description

A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.

Question mark icon indicates a help page and displays the associated help page in the right pane when selected.

WS icon indicates an example worksheet or tutorial. These worksheets open in a new tab in the Maple document.

D icon indicates a definition and displays the associated dictionary definition in the right pane when selected.

T icon indicates a Task template and displays the associated Task Template in the right pane when selected.

Hl[©l|E] |[~]

Viewing Help Pages as Documents
In the help system, examples are not executable.
The Maple help system allows you to open help pages as documents that you can execute.

To open a help page as a worksheet:

» With the help page displayed in the right pane of the help system, from the View menu, select Open Page as
Worksheet. A new worksheet tab opens and displays the help page as an executable document.

& Alternatively, in the help system toolbar, click the open current help page in a worksheet window icon.

Viewing Examples in 2-D Math

You can choose to view the examples in most help pages in either 2-D math or 1-D Math (Maple input) mode. The
default is 2-D Math.

To change the math mode:

In the Maple help system:

* From the View menu, select or clear the Display Examples with 2D math input check box.

. . XM2
* Click the 2-D Math icon, L y2.

Note: Some input in help pages displays as 1-D Math, no matter which option you have chosen. This is for Maple
procedures and other code that is best input in 1-D Math. For more information, see the helpnavigator help page.



1.7 Available Resources ¢ 39

Copying Examples

Instead of opening the entire page as a document, you can copy the Examples section only.

To copy examples:

1. With the help page displayed in the right pane of the help system, from the Edit menu, select Copy Examples.
. Close or minimize the Help Navigator and return to your document.

2
3. In your document, place the cursor at the location where you want to paste the examples.
4

. From the Edit menu, select Paste. The Examples section of the help page is inserted as executable content in your
document.

1.7 Available Resources

Your work with Maple is supported by numerous resources.
Resources Available through the Maple Help System

Help Pages

Use the help system to find information about a specific topic, command, package, or feature. For more information,
see The Maple Help System (page 36).

Dictionary

More than 5000 mathematical and engineering terms with over 300 figures and plots.

1. From the Help menu, select Maple Help.

2. Enter a search term. Dictionary entries that match your query are displayed in the left pane with a (o] icon.

Tutorials and the Maple Portal

The Maple Portal includes material designed for all Maple users, from new users to users who want more advanced
tutorials. The Maple Portal also includes specific sections for students and engineers. The Maple Portal includes:

* How Do ... topics that give quick answers to essential questions.

* Tutorials that provide an overview of topics from getting started to plotting, data manipulation, and interactive ap-
plication development.

» Navigation to portals with specialized information for students and engineers.

Access the portal in the Table of Contents under Getting Started.

Applications and Example Worksheets
Applications

Sample applications demonstrate how Maple can be used to find and document a solution to a specific problem. Some
applications allow for input or contain animations that you can run; however, their primary use is for demonstrations.
Topics include Bouncing Ball, Digital Filter Design, Frequency Domain System Identification, Harmonic Oscillator,
Image Processing, Radiator Design with CAD Systems, and Sunspot Periodicity.

Examples

Example worksheets are executable documents covering topics that demonstrate syntax or invoke a user interface to
make complex problems easy to solve and visualize. You can copy and modify the examples as needed. Topics include
Algebra, Calculus, Connectivity, Discrete Mathematics, General Numerics and Symbolics, and Integral Transforms.
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» Explore the available topics in the Table of Contents under Applications and Example Worksheets.

Manuals

You can access all of Maple's manuals from within Maple, including the Maple Programming Guide and this manual.
You can execute examples, copy content into other documents, and search the contents using the Maple Help System.

* Access the manuals in the Table of Contents under Manuals.

Maple's manuals are also available as PDFs on the Maplesoft website.

http://www.maplesoft.com/documentation_center

Task Templates

Set of commands with placeholders that you can use to quickly perform a task. For details, see Task Templates (page 27).
* From the Tools menu, select Tasks, and then Browse.

Quick Reference Card

The Quick Reference Card is a table of commands and information for new users that opens in a new window. It contains
hyperlinks to help pages for more information.

* From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2 (Command + F2, for Mac).
Website Resources

Student Help Center

The Student Help Center offers a Maple student forum, online math Oracles, training videos, and a math homework
resource guide.

http://www.maplesoft.com/studentcenter
Teacher Resource Center

The Teacher Resource Center is designed to ensure you get the most out of your Maple teaching experience. It provides
sample applications, course material, training videos, white papers, and tips.

http://www.maplesoft.com/TeacherResource
Application Center

Maple website resource for free applications related to mathematics, education, science, engineering, computer science,
statistics and data analysis, finance, communications, and graphics. Many applications are available in translations
(French, Spanish, and German).

http://www.maplesoft.com/applications
Training

Maplesoft offers a comprehensive set of complementary training materials. From complete training videos to recorded
training seminars to downloadable documentation, you have many options to get familiar with Maplesoft products. In
addition, custom training sessions can be created to meet your needs.

http://www.maplesoft.com/support/training


http://www.maplesoft.com/documentation_center
http://www.maplesoft.com/studentcenter
http://www.maplesoft.com/TeacherResource
http://www.maplesoft.com/applications
http://www.maplesoft.com/support/training
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MaplePrimes

A web community dedicated to sharing experiences, techniques, and opinions about Maple and related products, as
well as general interest topics in math and computing.

http://www.mapleprimes.com

Online Help

All of Maple's help pages are available online.
http://www.maplesoft.com/support/help
Technical Support

A Maple website containing FAQs, downloads and service packs, links to discussion groups, and a form for requesting
technical support.

http://www.maplesoft.com/support

For a complete list of resources, refer to the MapleResources help page.


http://www.mapleprimes.com
http://www.maplesoft.com/support/help
http://www.maplesoft.com/support
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2 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems
in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-
modify interactive documents. You can also devise custom solutions using the Maple programming language. While
you work, you can document your process, providing text descriptions.

2.1 In This Chapter

Section Topics

Introduction (page 43) * Comparison of Document and Worksheet Modes

Entering Expressions (page 44) - Overview of tools for creating |+ Palettes

complex mathematical expressions « Symbol Names

¢ Mathematical Functions

Evaluating Expressions (page 47) - How to evaluate expressions |* Displaying the Value Inline

 Displaying the Value on the Following Line

Editing Expressions and Updating Output (page 48) - How to |+ Updating a Single Computation

update expressions and regenerate results + Updating a Group of Computations

» Updating All Computations in a Document

Performing Computations (page 48)- Overview of tools for * Computing with Palettes

performing computations and solving problems « Context Panel

¢ Assistants and Tutors

2.2 Introduction

Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then
evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of
Document mode.

Document mode sample:
Find the value of the derivative of ln(x2 + 1) at x=4.

2 X 8
ln(x2 + 1) differentiate w.r.t. x X2 +1 evaluate at point 17

sin .
Integrate [ x] over the interval [0, 7] .

o)l )oo

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The
Worksheet mode supports the features available in Document mode described in this chapter. For information on using
Worksheet mode, see Chapter 3, Worksheet Mode (page 57). Note: To enter a Maple input prompt while in Document
mode, click » in the Maple toolbar.

43
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Important: In any Maple document, you can use Document mode and Worksheet mode.

Interactive document features include:

» Embedded graphical interface components, like buttons, sliders, and check boxes

* Automatic execution of marked regions when a file is opened

 Tables

 Character and paragraph formatting styles

* Hyperlinks

These features are described in Chapter 7, Creating Mathematical Documents (page 227).

Note: This chapter and Chapter 1 were created using Document mode. All of the other chapters were created using
Worksheet mode.

2.3 Entering Expressions

Chapter 1 provided an introduction to entering simple expressions in 2-D Math (see Entering Expressions (page 13)).
It is also easy to enter mathematical expressions, such as:

-x x<0
X =7 0 x=0

« Piecewise-continuous functions: X 0<x

T e—1
« Limits: 8(x) = eh—I>n0€|x|

J2 =1+ 1

2 +

1
2 +
+ Continued fractions: 2+ -

and more complex expressions.

Mathematical expressions can contain the following objects.

* Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, i, o, ...
_ 0

+ Operators: +, -, L/, -, J’ th»na’ ox .

¢ Constants: T, €, ...

i
. COS| — |,
+ Mathematical functions: sin(x), [ 3 ] r2), ..
+ Names (variables): X, Y, Z, 0, B, ...
 Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding
key, for example, 9, =, >, or x. Most symbols are not available on the keyboard, but you can insert them easily using
two methods, palettes and symbol names.
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Example 1 - Enter a Partial Derivative

To insert a symbol, you can use palettes or symbol names.

0 -

—e
Enter the partial derivative 0t using palettes.

Action Result in Document
1. In the Calculus palette, click the partial a
a _
differentiation item @z 7 . Maple inserts the partial dx
derivative. The variable placeholder is selected.

2. Enter t, and then press Tab. The expression a
placeholder is selected. —_—

3. Enter e tz Note: To enter the exponential e, use
the Expression palette or the Common Symbols
palette. Here, we use the ;.- template from the
Expression palette.

Click the template. The exponent placeholder is
selected. Enter the exponent.

difF {inline partial) :;x
diff (inline) % |
dffoe ATEE |
\diff_table (function and derivatives) PDEtools [diff fable](expr)
diff_table (representation of function and derivatives)  DETools [diff fable |(expr |
diffalg diffals
_dlff_opzda (differential operatar) DETools | diffop2de (oper, ¥} ™|
< il >

To evaluate the derivative and display the result inline, press Ctrl+= (Command+=, for Macintosh) or Enter. For
more information, see Computing with Palettes (page 48).
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You can enter any expression using symbol names and the symbol completion list.

Action Result in Document

1. Begin typing the name of the symbol,
diff, and press the symbol completion
key (see Shortcut Keys by
Platform (page xiii)).

2. Select the partial differentiation item, |, -2

-

3. Replace the placeholder with t. Use the | s=z—»
right arrow to move out of the

denominator. Enter twice, as in the
previous example.

Example 2 - Define a Mathematical Function

Define the function y-. - ,which doubles its input.

Action

Result in Document

1. In the Expression palette, click the single variable

function definition item, th Ce- .

twice =@ — y

2. Replace the placeholder f with the function name, Xx.
Press Tab to move to the next placeholder.

twicg i= X — §
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Action Result in Document

3. Replace the parameter placeholder, a, with the twice := x — 2 X
independent variable 2 Xx. Press Tab.

4. Replace the output placeholder, y, with the desired twice(1342)
output, twice := x+— 2 X

2684

twice(y—z)=2y—-2z
- =2X

Note: To insert the right arrow symbol X — 2 X, you can also enter the characters -> in Math mode. In this case,
symbol completion is automatic.

2 7 85
Important: The expression 9 11 is different from the function 99 .

For more information on functions, see Functional Operators (page 273).

2.4 Evaluating Expressions

To evaluate a mathematical expression, place the cursor in the expression and press Ctrl + = (Command + =, for
Macintosh). That is, press and hold the Ctrl (or Command) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.

2 7 85
— _l’_ - -

9 11 = 99
In mathematical content, pressing Enter evaluates the expression and displays it centered on the following line. The
cursor moves to a new line below the output.

+

_ @2.1)

By default, Maple labels output that is generated by pressing Enter. For information on equation labels, see Equation
Labels (page 70). In this manual, labels are generally not displayed.

You can use the basic algebraic operators, such as (2 X —x+ 1) - (XZ +2x+ 12) and X —3 x—11 , with
most expressions, including polynomials—see Polynomial Algebra (page 112) and matrices and vectors—see Matrix
Arithmetic (page 125).

-12 24 297
81 207 87

-4 8 99
27 69 29

1=
Tip: The Enter key has a number of uses.
* Pressing Enter with your cursor in a math expression exeuctes it and evalutes it on a new line.

* Pressing Enter in text inserts a line break.

* Pressing Enter when at the beginning of a line (the Home position) inserts a new line above the current line.
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For more information on these concepts, refer to the Using Document Blocks help page.

Tip: If you want to change an input/output expression from evaluate and display inline to evaluate and display on a
new line, with your cursor in the input expression, from the Evaluate menu or the Context Panel, clear the check box
beside Evaluate and Display Inline.

2.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are /ive. That is, you can edit expressions and quickly recalculate
results.

To update one computation:
1. Edit the expression.

2. Press Ctrl + = (Command + =, for Macintosh) or Enter.
The result is updated.

To update a group of computations:
1. Edit the expressions.
2. Select all edited expressions and the results to recalculate.
.
3. Click the Execute toolbar icon 3:® ¢
All selected results are updated.
To update all output in a Maple document:
0 2
* Click the Execute All toolbar icon ;,:C 1

All results in the document are updated.

Note: Be careful when you revisit a document and make changes, as it's possible to produce a document with worksheet
commands out of order (i.e. where a certain command won't work properly without a later one).

2.6 Performing Computations

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning
Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:
* Palettes
* The Context Panel

e Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also supports Maple commands. For information
on commands, see Commands (page 59) in Chapter 3, Worksheet Mode (page 57).

Important: In Document mode, you can execute a statement only if you enter it in Math mode. To use a Maple command,
you must enter it in Math mode.

Computing with Palettes

As discussed in Entering Expressions (page 44), some palettes contain mathematical operations.
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To perform a computation using a palette mathematical operation:
1. In a palette that contains operators, such as the Expression or Calculus palettes, click an operator item.
2. In the inserted item, specify values in the placeholders.

3. To execute the operation and display the result, press Ctrl+= (Command+=, for Macintosh) or Enter.

For example, to evaluate -2 te’ e inline:
1. Using the Calculus palette, enter the partial derivative. See Example 1 - Enter a Partial Derivative (page 45).

2. Press Ctrl+= (Command-+=, for Macintosh).

11
T e

olr

9
Plat Builder
Evaluate and Display Infine
Explore
Apply a Command

Approximate

Computing with the Context Panel

The context panel is a collection of tools and operations that are appropriate for a particular expression. The context
panel changes according to the expression, table, or region that you click on. See Figure 2.1.

o=
Teals Window Help
5T > < 3 G W C e a’a /..
| Untitied (3) X |3 "Uebted () X
s [ 2 et ~|[Tmeshenkoman -] [12 -] B[I]% [&2 @

Figure 2.1: Context Panel

To display the context panel:
1. Click the expression.

2. Move your mouse cursor over Pin Open Context Panel (~ ), or click it to fix the context panel in place.
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The context panel is displayed.

at 10 digits
>

You can evaluate expressions using context panel options. The Evaluate and Display Inline operation (see Figure 2.1)
is equivalent to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an equal sign (=) and then the value
of the expression.

Alternatively, press Enter to evaluate the expression and display the result centered on the following line.
For more information on evaluation, see Evaluating Expressions (page 47).

From the context panel, you can also select operations different from evaluation. To the right of the expression, Maple
inserts a right arrow symbol (—) and then the result.
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For example, use the Approximate operation to approximate a fraction: 0.6666666667 COS(X2 ), COS(X2 )

You can perform a sequence of operations by repeatedly using context panel options. For example, to compute the
differentiate w.r.t. x

derivative of use the Differentiate operation on the expression, and then to evaluate the result
at a point, use the Evaluate at a Point operation on the output and enter 10:

_2 sin(¥?) x Svaluateatpoint 54 in(100) 2 X

Note: For the sequence of operations to make sense when being read from left to right, stale results are deleted before
new operations are performed.

For example:

differentiate w.r.t. x

Enter the expression X

Click on the expression and use the Differentiate option from o x 2 _differentiate wr.t. x
the context panel to differentiate with respect to x.

Click on 2x and use the Integrate option from the context panel

2y integrate w.r.t. X XZ XZ differentiate w.r.t. x
. . R
to integrate with respect to x.

Click on 2x again and use the Differentiate option to differentiate 2 2
with respect to x.
Plot Builder
. . . . Evaluate and Display Inline
Notice how the result of integration with respect to x has been Bplore
replaced with the result of differentiation with respect to x so that e ]
the sequence of operations makes sense. 5 ame
10
20
50 5
ifferentiate w.r.t. x 100_trions >
2 x Afferentiate 2 e ,\
2
3

The following subsections provide detailed instructions on performing a few of the numerous operations available using
context-sensitive operations in the context panel.

Approximating the Value of an Expression

To approximate a fraction numerically:
1. Enter a fraction.
2. Click the fraction to display the context panel. See Figure 2.2.

3. From the context panel, select Approximate, and then the number of significant digits to use: 5, 10, 20, 50, or 100.

at 10 digits
>

Figure 2.2: Approximating the Value of a Fraction

2
0.6666666667 — 3

You can replace the inserted right arrow with text or mathematical content.
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is approximately equal to

):

To replace the right arrow (
1. Select the arrow and text. Press Delete.

2. Enter the replacement text or mathematical content.
Note: To replace the right arrow with text, you must first press F5 to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol ~=.

2
0.6666666667 3 =
12
T" + % =12
Move to Right
Negate Relation
Plots
Right-hand Side
Simplify .
Mol Bl
Isolate Expression for »
Numesically Solve
Numerically Solve (w/complex)
Numerically Solve from point
Obtain Selutions for » >
Solve >
Sm:e(exm-:m 7 )g _ i — 1 2
Solve (general solution)
0.6666666667 R 3 T

Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information
on symbolic and numeric computations, see Symbolic and Numeric Computation (page 76).

To solve an equation:
1. Enter an equation.
2. Display the context panel. See Figure 2.3.

3. From the context panel, select Solve or Numerically Solve in the Solve menu item.

solve
—

Figure 2.3: Finding the Approximate Solution to an Equation

EIR v U V35 U O SN T SV S P2 B O S S

= 14 . ’ T 14 - 3 - solve
‘Eng.: 1t inv
o o m | 290C
-2.200603126, 2.337021648 unit 2.9s
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For more information on solving equations, including solving inequations, differential equations, and other types of
equations, see Solving Equations (page §2).

Using Units

You can create expressions with units. To specify a unit for an expression, use the Units palette. See Figure 2.4.

simplify units

Figure 2.4: Units Palette

To insert an expression with a unit:
1. Enter the expression.

2. In a unit palette, click a unit symbol.
Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:
1. Enter the expression using the units palettes to insert units.
2. Click the expression.

3. From the context panel, select the Simplify menu and then Simplify.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.
1 3 0 -2 -1
4 2 -1 5 7
0 -3 5 4 -7

203.4482759 A |1 -1 3 6 5

For more information on using units, see Units (page 95).

Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. For details on as-
sistants and tutors, see Point-and-Click Interaction (page 24).

Assistants and tutors can be launched from the Tools menu or the Context Panel for an expression. For example, you
can use the Linear System Solving tutor to solve a linear system, specified by a matrix or a set of equations.
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Example 3 - Using the Context Panel to Open the Linear System Solving Tutor

Use the Linear System Solving tutor to solve the following system of linear equations, written in matrix form:

& Linear Algebra - Linear System Solving =3
[ Gatisian Eliminabon | | Gauss Jordan Elmination |
Cancel
Action Result in Document
1. In a new document block, create the matrix or set ||t mnsion =

File Edt Help

of linear equations to be solved.

Mitoly

EdtManx Saive System of Equations

. Snap
v | [ esem Alsteps Gose

2. Load the Student[LinearAlgebra] package. From | Loading Student:-LinearAlgebra
the Tools menu, select Load Package — Student
Linear Algebra. This makes the tutors in that
package available. For details, see Package
Commands (page 32).

3. Click the matrix and from the context panel select

Wk Solve the system of equations in Row-Echelon Form [
Student Linear Algebra — Tutors — Linear Linear System of Equations
System Solving.... The Linear System Solving [13 02 10004 the matziz has been
dialog appears, where you can choose the solving R A S i b i o itheren
method. Gaussian Elimination reduces the matrix T B , ols g E CI ? K
to row-echelon form, then performs
back-substitution to solve the system. Gauss
Jordan Elimination reduces the matrix to reduced
row-echelon form, where the equations are already
solved. For this example, choose Gaussian —
Elimination.

Close Change the marix Canced

4. The Gaussian Elimination dialog opens. Youcan|
specify the Gaussian elimination step-by-step, or
you can use the Next Step or All Steps buttons to 1 3 O - 2 - 1
have Maple perform the steps for you.

5. Once the matrix is in row-echelon

(upper-triangular) form, click the Solve System 4 2 _ 1 5 7
button to move to the next step.
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Action Result in Document
6. The Solve the system of equations in =
Row-Echelon Form dialog appears. Click the llne ar S Olve tutor
buttons on the right to calculate the solution: first AN
find the Equations, then solve for each variable. 7
Click the Solution button to display the solution
in the tutor.

7. Click the Close button to return the solution to
your document.

For more information on linear systems and matrices, see Linear Algebra (page 118).
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3 Worksheet Mode

The Worksheet mode of the Standard Worksheet interface is designed for:

* Interactive use through Maple commands, which offers advanced functionality and customized control not available
using the context panel or other syntax-free methods

* Programming using the powerful Maple language

Using Worksheet mode, you have access to all of the Maple features described in Chapter 1, and most of those described
in Chapter 2, including:

* Math and Text modes
 Palettes

» The context panel
 Assistants and tutors

For information on these features, see Chapter 1, Getting Started (page 1) and Chapter 2, Document Mode (page 43).

Note: Using a document block, you can use all Document mode features in Worksheet mode. For information on
document blocks, see Document Blocks (page 35).

Note: This chapter and the following chapters except Chapter 7 were created using Worksheet mode.

3.1 In This Chapter

Section Topics

Input Prompt (page 58) - Where you enter input * The Input Prompt (>)
* Suppressing Output
e 2-D and 1-D Math Input

 Input Separators

Commands (page 59)- Thousands of routines for performing |+ The Maple Library
computations and other operations « Top-Level Commands
* Mathematical Functions
* Package Commands

 Lists of Common Commands and Packages

Palettes (page 63) - Items that you can insert by clicking or » Using Palettes
dragging

The Context Panel (page 65)- Clickable access to common » Using the Context Panel
operations

.

Assistants and Tutors (page 66)- Graphical interfaces with buttons
and sliders

Launching Assistants and Tutors

Task Templates (page 66) - Sets of commands with placeholders
that you can insert and use to perform a task

Viewing Task Templates
* Inserting a Task Template
 Performing the Task

.

Text Regions (page 67) - Areas in the document in which you
can enter text

Inserting a Text Region

» Formatting Text

57
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Section Topics

Names (page 68) - References to the expressions you assignto |¢ Assigning to Names

them * Unassigning Names

¢ Valid Names

Equation Labels (page 70) - Automatically generated labels that|* Displaying Equation Labels
you can use to refer to expressions + Referring to a Previous Result
» Execution Groups with Multiple Outputs
» Label Numbering Schemes

» Features of Equation Labels

3.2 Input Prompt

. > . .
In Worksheet mode, you enter input at the Maple input prompt (" ). The default mode for input is Math mode (2-D
Math).

To evaluate input:

¢ Press Enter.

Maple displays the result (output) below the input.

T

3
S
For example, to find the value of [ 3 ] , enter the expression, and then press Enter.

3T
>sm(3]

ﬂ (3.1)

8
For example, compute the sum of two fractions.
2 7
— + —_—
>9 11
85
— 3.2
99 (3.2)

A set of Maple input and its output are referred to as an execution group.

In the worksheet, the semicolon as a statement terminator is optional.

Suppressing Output

To suppress the output, enter a colon (:) at the end of the input.

— 2 7.
T
1-D Math Input

You can also insert input using 1-D Math mode. The input is entered as a one-dimensional sequence of characters. 1-
D Math input is red.
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To enter input using 1-D Math:

At the input prompt, press F5 or click the Text button in the context bar, __ ., , to switch from 2-D Math to 1-D
Math.

> 12342 - 29857/120;

1785623
120

As with 2-D math, in 1-D math, if you use a colon, Maple suppresses the output.

29857
120

_123° -
To set the default input mode at a prompt to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.

2. On the Display tab, in the Input display drop-down list, select Maple Notation.

3. Click Apply to Session (to set for only the current session) or Apply Globally (to set for all Maple sessions).
To convert between 2-D Math input and 1-D Math input:

1. Select the 2-D (or 1-D) Math input.

2. From the Format menu, select Convert To, and then 1-D Math Input (or 2-D Math Input).

Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

> sqrt(4.4); tan(3.2);
2.097617696
0.05847385446

If you do not specify a semicolon or colon, Maple interprets it as a single input. This can either give unexpected results
or an error. Notice that the following example gives an error in 1-D math but in 2-D math this is interpreted as multi-
plication.

> sqrt(4.4) tan(3.2)
Error, missing operator or ;°
>,/ 4.4 tan(3.2)
0.1226557919

3.3 Commands

Maple contains a large set of commands and a powerful programming language. Most Maple commands are written
using the Maple programming language.

You can enter commands using 1-D or 2-D Math. 1-D Math input is recommended when programming in Maple. Basic
Programming (page 293) provides an introduction to Maple programming.

To learn how to use Maple commands, see the appropriate help page, or use task templates. For more information, see
The Maple Help System (page 36) and Task Templates (page 66).
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The Maple Library

Maple's commands are contained in the Maple library. There are two types of commands: top-level commands and
package commands.

* The top-level commands include many of the most frequently used Maple commands, as well as an extensive list
of mathematical functions.

» Packages contain related specialized commands in areas such as calculus, linear algebra, vector calculus, and code
generation.

For a complete list of packages and commands, refer to the index/help help pages. For information on the Maple Help
System, see The Maple Help System (page 36).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (( )) containing any parameters. This is referred
to as a calling sequence for the command.

|command(arguments) |

Note: In 1-D Math input, include a semicolon or colon at the end of the calling sequence.

For example, to differentiate an expression, use the diff command. The required parameters are the expression to dif-
ferentiate, which must be specified first, and the independent variable.

> diff(tan(x) sin(x), x)
(1 + tan(x)z) sin(x) + tan(x) cos(x)

Mathematical Functions

For a complete list of commands that implement mathematical functions, such as Bessell and AiryAi, available in the
library, refer to the initialfunctions help page.

Bessell(0.1, 1)
> AiryAi(2.2)

47.53037086

For detailed information on the properties of a function, use the FunctionAdvisor command.

> FunctionAdvisor ('definition’, Bessell)

2
zaoFl[; a+1; Z]
I(z)= , With no restrictions on (a, z)

a ra+1)2°

This definition is displayed using the typeset form of the Bessell function, the hypergeometric function (hypergeom)
and the Gamma function (GAMMA). To see the function names rather than the typeset form, use lprint:

> Iprint(%)

[BesselI(a, z) = z”a*hypergeom([], [a+1], (1/4)*z"2)/(GAMMA (a+1l)*2”a), ‘with no restrictions

on " (a, z)]

For detailed information on how to use a function in Maple, refer to its help page.
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For example:

> ? Bessel

Another way to access help is to select the word for which you want help and use the shortcut key for context help, F2
(Control + Shift + ?, for Mac).

Top Commands

Here are a few of the most frequently used Maple commands. A complete list of top-level commands is available on
the index/function help page.

Table 3.1: Top Commands

Command Name Description

plot and plot3d Create a two-dimensional and three-dimensional plot of functions.

solve Solve one or more equations or inequalities for their unknowns.

fsolve Solve one or more equations using floating-point arithmetic.

eval Evaluate an expression at a given point.

evalf Numerically evaluate expressions.

dsolve Solve ordinary differential equations (ODEs).

int Compute an indefinite or definite integral.

diff Compute an ordinary or partial derivative, as the context dictates.

limit Calculate the limiting value of a function.

sum For symbolic summation. It is used to compute a closed form for an indefinite or definite sum.

assume/is Set variable properties and relationships between variables. Similar functionality is provided by the
assuming command.

assuming Compute the value of an expression under assumptions.

simplify Apply simplification rules to an expression.

factor Factor a polynomial.

expand Distribute products over sums.

normal Normalize a rational expression.

convert Convert an expression to a different type or form.

type Type-checking command. In many contexts, it is not necessary to know the exact value of an

expression; it suffices to know that an expression belongs to a broad class, or group, of expressions
that share some common properties. These classes or groups are known as types.

series Generalized series expansion.

map Apply a procedure to each operand of an expression.

Package Commands

To use a package command, the calling sequence must include the package name, and the command name enclosed
in square brackets ([ ]).

|package [command] (arguments)

If you are frequently using the commands in a package, load the package.

To load a package:

+ Use the with command, specifying the package as an argument.

The with command displays a list of the package commands loaded (unless you suppress the output by entering a colon
at the end of the calling sequence).
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After loading a package, you can use the short form names of its commands. That is, you can enter the commands
without specifying the package name.

For example, use the NLPSolve command from the Optimization package to find a local minimum of an expression
and the value of the independent variable at which the minimum occurs.

sin(x)

- Optimization| NLPSolve] [ ,x=1.1 5]

[—0.0913252028230577, [x=10.9041216489198] ]
> with(Optimization);

[ ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]
NLPSoIve[ sin(x) o4 ..15]
> X

[-0.0913252028230576718, [x=10.9041216700744900] |
For more information on optimization, see Optimization (page 140).
To unload a package:
» Use the unwith command, specifying the package as an argument.
> unwith(Optimization)

Alternatively, use the restart command. The restart command clears Maple's internal memory. The effects include
unassigning all names and unloading all packages. For more information, refer to the restart help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between
examples.

Some packages contain commands that have the same name as a top-level command. For example, the plots package
contains a changecoords command. Maple also contains a top-level changecoords command.

> with(plots) :

After the plots package is loaded, the name changecoords refers to the plots[changecoords] command. To use the
top-level changecoords command, unload the package or use the restart command. (For alternative methods of accessing
the top-level command, see the rebound help page.)

Top Packages

Here are a few of the most frequently used Maple packages. A complete list of packages is available on the index/pack-
age help page.

Table 3.2: Top Packages

Package Name Description

CodeGeneration The Code Generation package is a collection of commands and subpackages that enable the
translation of Maple code to other programming languages, such as C, C#, Fortran, MATLAB®,
Visual Basic®, JavaTM, Julia, Perl, and Python®.

LinearAlgebra The Linear Algebra package contains commands to construct and manipulate Matrices and
Vectors, and solve linear algebra problems. LinearAlgebra routines operate on three principal
data structures: Matrices, Vectors, and scalars.
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Package Name Description

Optimization The Optimization package is a collection of commands for numerically solving optimization
problems, which involve finding the minimum or maximum of an objective function possibly
subject to constraints.

Physics The Physics package implements computational representations and related operations for most
of the objects used in mathematical physics computations.

RealDomain The Real Domain package provides an environment in which Maple assumes that the basic
underlying number system is the field of real numbers instead of the complex number field.

ScientificConstants The Scientific Constants package provides access to the values of various physical constants,

for example, the velocity of light and the atomic weight of sodium. This package provides the
units for each of the constant values, allowing for greater understanding of an equation. The
package also provides units-matching for error checking of the solution.

ScientificErrorAnalysis

The Scientific Error Analysis package provides representation and construction of numerical
quantities that have a central value and an associated uncertainty (or error), which is a measure
of the degree of precision to which the quantity's value is known. Various first-order calculations
of error analysis can be performed with these quantities.

Statistics The Statistics package is a collection of tools for mathematical statistics and data analysis. The
package supports a wide range of common statistical tasks such as quantitative and graphical
data analysis, simulation, and curve fitting.

Student The Student package is a collection of subpackages designed to assist with teaching and learning
standard undergraduate mathematics. The many commands display functions, computations, and
theorems in various ways, including stepping through important computations.

The Student package contains the following subpackages:
* Basics - fundamental math concepts

* Calculusl - single-variable calculus

* LinearAlgebra - linear algebra

* MultivariateCalculus - multivariate calculus

* NumericalAnalysis - numerical analysis

* Precalculus - precalculus

« Statistics - statistics

* VectorCalculus - multivariate vector calculus

Units The Units package contains commands for unit conversion and provides environments for
performing calculations with units. It accepts approximately 300 distinct unit names (for example,
meters and grams) and over 550 units with various contexts (for example, standard miles and
U.S. survey miles). Maple also contains two Units palettes that allow you to enter the unit for
an expression quickly.

VectorCalculus The Vector Calculus package is a collection of commands that perform multivariate and vector

calculus operations. A large set of predefined orthogonal coordinate systems is available. All
computations in the package can be performed in any of these coordinate systems. It contains a
facility for adding a custom but orthogonal coordinate system and using that new coordinate
system for your computations.

3.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. For example, see Figure 3.1.
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W Caloulus

limf —f —f frx) ()

[y

()

G |

[Jrosffroas ] [ree

171 17171

Figure 3.1: Calculus Palette

You can use palettes to enter input.
[
For example, evaluate a definite integral using the definite integration item *, in the Calculus palette.

In 2-D Math, clicking the definite integration item inserts:

X
2

J £ dx

X
s 1

1. Enter values in the placeholders. To move to the next placeholder, press Tab.
2. To evaluate the integral, press Enter.
1
J tanh(x) dx

>0

-In(2) + ln(e'1 +e)
In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.
> int(f,x=x[1]..x[2]);

Specify the problem values (using the Tab to move to the next placeholder), and then press Enter. Note: If pressing
the Tab key inserts a tab, under the Format menu, toggle Tab Navigation. Then the Tab key will move the cursor to
the next placeholder.

> int(tanh(x), x = 0..1);
-In(2) +ln(e'1+e)

Note: Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When
the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on viewing and using palettes, see Palettes (page 15) in Chapter 1.
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3.5 The Context Panel

The context panel is a collection of tools and operations that are appropriate for a particular expression. The context
panel changes according to the expression, table, or region that you click on. See Figure 3.2.

[> 946929| - factor integer

046929

Plot Builder
Explore

Apply a Command
Aszzign to a Name
Dirvisors

Integer Factors
Plots

Prime Factors
Figure 3.2: Integer Context Panel

You can use the context panel to perform operations on 2-D Math, including output.

To use the context panel:

1. Click the expression.

2. Move your mouse cursor over Pin Open Context Panel ( << ), or click it to fix the context panel in place.

3. From the context panel, select a tool or operation.

Maple inserts a new execution group containing:
» The calling sequence that performs the operation

* The result of the operation
Example - Using the Context Panel

Determine the rational expression (fraction) that approximates the floating-point number 0.3463678 + 1.7643.

Action Result in Document
1. Enter and execute the expression. > 0.3463678 + 1.7643

2.1106678 (3.3)
2. Click the output floating-point number. > 03463678 +1.7643 : 21106678

2.1106678 m
Plot Builder
Explore
Apply a Command
Assign to a Name
Identify
Plots

[Conversions =|

Continued Fraction
Exact Ratignal

Rational Expanszion

3. From the context panel, select Conversions — Rational. The |~ convert( (3.3), 'rational )
inserted calling sequence includes an equation label reference
to the number you are converting. 32270

15289

Notice that an equation label reference has been used. For information on equation labels and equation label references,
see Equation Labels (page 70).
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For more information on the Context Panel, see Computing with the Context Panel (page 49) in Chapter 2.

3.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. See Figure 3.3.

¥ ODE Analyzer Assistant (===
Differential Equations Conditions Parameters
d . & yio=1
E_\.', B - =M =M1
Edit... Edit... Edit...
: Salve Numerically 1| soive Symbolcally Classify Help Quit

Figure 3.3: ODE Analyzer Assistant

Launching an Assistant or Tutor

To launch an assistant or tutor:
1. Open the Tools menu.
2. Select Assistants or Tutors.

3. Navigate to and select one of the assistants or tutors.

For more information on assistants and tutors, see Assistants (page 24) in Chapter 1.

3.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands
required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the com-
mands, or click a button.

The Task Browser (Figure 3.4) organizes task templates by subject.

To launch the Task Browser:

* From the Tools menu, select Tasks, and then Browse.

You can also browse the task templates in the Table of Contents of the Maple Help System.
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[ @ Browse Tasks

(o@] = |

[ | Calculus - Differential
= |y Caleulus - Integral
- . Integration
. Approximate Integration
, Methods of Integration
Applications
[1] Arc Length of a Univariate Function
- |, Solids of Revolution
Surface Area

|
- || Series

[ |, Calculus - Multivariate

(- | Caleulus - Vector

----- Convert Expression to Function
[+ ) Curve Fitting

[#- | Differential Equations
[ || Document Templates
[ || eBook Metadata

[ | Evaluating

[~ | Geometry

[~ | Integers

[ | Linear Algebra

[~ |, Lists
[
[
[
[
[
[
[E3]

| Maple T.A.
- | Plots
| Polynomials
- | Statistics
| Transformations
-, Units, Constants, and Errors
| User Tasks

File WView
----- Overview 4 o Ci 4 il —
6 Algebra N l Copy Task to Clipboar, l l Insert Default Content l l Insert Minimal Content l

[ Insert into New Worksheet [ Display task markers

¥ Volume of Revolution

Description

> sin(x) cos(x) + 1,0..

|x.:|;:|

sin(x) cos(x) + 1, [}..% T

Calculate the volume of revolution:

> Student] Calculus I VohumeOfRevolwtion]((1))

g 2
+_
T 16?[

> evalf((2))
8.693245131

Display a plot using the owput=plor option:

scaling = constrained caption="")

Calculate the volume of revolution for a solid of revolution when
a function is rotated about the horizontal or vertical axis.

Enter the function as an expression and specify the range:

Display the floating-point value using the evalf command:

> Student] Calculus I VolumeOfRevolwtion]((1), output = plot,

»

m

0)]

@

&)

4 UL

Task, VolumeOfRevUnivariateFon

Figure 3.4: Task Browser

For details on inserting and using task templates, see Task Templates (page 27). You can also create your own task
templates for performing common tasks. For details, refer to the creatingtasks help page.

3.8 Text Regions

To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

* In the toolbar, click the Text region icon T

The default mode in a text region is Text mode.
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In a text region, you can:

» Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text

Text|Makh

mode and Math mode, press F5 or click the Math and Text toolbar icons,

Note: To change a math region to nonexecutable mathematical content, use Shift + F5.

* Insert any palette item. Palette items are inserted in Math mode (2-D Math). Note: After you insert a palette item,
you must press F5 or click the toolbar icon to return to Text mode.

You can format text in a text region. Features include:
* Character styles

 Paragraph styles

» Sections and subsections

e Tables

For more information on formatting documents, see Creating Mathematical Documents (page 227).

3.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a name or add an equation label to it.
Then you can quickly refer to the expression using the name or an equation label reference. For information on labels,
see the following section, Equation Labels (page 70).

Note: Through the Variable Manager you can manage the top-level assigned variables currently active in your Maple
Session. For more information about the Variable Manager, see the Variable Manager help page. For Maple workbooks,
you can use the Variable Manager palette to return to the saved state of your variables.

Assigning to Names

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program),
and other Maple objects.

Initially, the value of a name is itself.
>dad
a
The assignment operator (:=) associates an expression with a name.
>A=T
a=mn
Recall that you can enter 7 using the following two methods.

* Use the Common Symbols palette.

* In 2-D Math enter pi, and then press the symbol completion shortcut key. See Shortcuts for Entering Mathematical
Expressions (page 5).
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When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:
> cos(a)
-1
For information on Maple evaluation rules, see Evaluating Expressions (page 285).
Mathematical Functions
To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

> cube:= x —>x3:

For information on creating functions, see Example 2 - Define a Mathematical Function (page 46).

> cube(3); cube(1.666)
27
4.624076296

Note: To insert the right arrow, enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol —.
In 1-D Math, the characters are not replaced.

For example, define a function that squares its argument.
> square := x -> x"2:
> square(32) ;
1024
For more information on functions, see Functional Operators (page 273).
Protected Names
Protected names are valid names that are predefined or reserved.
If you attempt to assign to a protected name, Maple returns an error.

> sin:=2

Error, attempting to assign to “sin’ which is protected. Try declaring “local sin’; see

?protect for details.

For more information, refer to the type/protected and protect help pages.

Unassigning Names

The unassign command resets the value of a name to itself. Note: You must enclose the name in right single quotes

(V V).

> unassign('a')
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a

Right single quotes (unevaluation quotes) prevent Maple from evaluating the name. For more information on unevaluation
quotes, see Delaying Evaluation (page 290) or refer to the uneval help page.

See also Unassigning a Name Using Unevaluation Quotes (page 292).
Unassigning all names:

The restart command clears Maple's internal memory. The effects include unassigning all names. For more information,
refer to the restart help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between
examples.

Valid Names

A Maple name must be one of the following.
* A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character.

* A sequence of characters enclosed in left single quotes (" 7).

Important: Do not begin a name with an underscore character. Maple reserves names that begin with an underscore
for use by the Maple library.

Examples of valid names:

ca

« al

* polynomial

* polynomiall_divided by _polynomial2

e "2a

. xy'

3.10 Equation Labels

Maple marks the output of each execution group with a unique equation label.

Note: The equation label is displayed to the right of the output.
o Jsm(x) dx

-cos(X) (34

Using equation labels, you can refer to the result in other computations.

. [(3.4) ax

-sin(x) (3.5)
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Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display is turned off, complete both of the
following operations.

* From the Format menu, select Equation Labels, and then ensure that Worksheet is selected.

* In the Options dialog (Tools—Options), on the Display tab, ensure that Show equation labels is selected.

Referring to a Previous Result

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to
refer to a previous result, insert an equation label reference.

To insert an equation label reference:

1. From the Insert menu, select Label. Alternatively, double-click on the equation label (to the far right side of the
output) or press Ctrl+L; Command+L, Macintosh.

2. In the Insert Label dialog (see Figure 3.5), enter the label value, and then click OK.

Insert Label
Type: Equation v
Identifier:

i ] [ Cancel

Figure 3.5: Insert Label Dialog
Maple inserts the reference.
For example:

To integrate the product of (3.4) and (3.5):

Action Result in Document
1. In the Expression palette, click the indefinite integration item r
. = | fdx
J fdx . .. . . :
. The item is inserted and the integrand placeholder is
highlighted.
2. Press CtrI+L (Command+L, for Macintosh). . [+ dr
3. In the Insert Label dialog, enter 3.4. Click OK. Insert Label
Tvpe: Equation v
Tdsnifier: | 3.4]
[ oK ] [ Cancel
4. Press *. r
> [(3.4)(3.5)dx
5. Press Ctrl+L (Command+L, for Macintosh). -
6. In the Insert Label dialog, enter 3.5. Click OK.
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Action Result in Document

7. To move to the variable of integration placeholder, press Tab. . J’ (3.4)-(3.5) dx

8. Enter x.

9. To evaluate the integral, press Enter. Sin(x)2

3.6
> (3.6)

Execution Groups with Multiple Outputs

An equation label is associated with the last output within an execution group.

(55 ) reos( £
>\35)" 6
0.3265306122
%ﬁ (3.7)
> (3.7)2

(3.8)

A jw

Label Numbering Schemes

You can number equation labels in two ways:
* Flat - Each label is a single number, for example, 1, 2, or 3.

* Sections - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation
in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

* From the Format menu, select Equation Labels — Label Display. In the Format Labels dialog (Figure 3.6), select
one of the formats.

* Optionally, enter a prefix.

> ’.sm(x) dx
‘ —cos(x) (Cuestion1)
|:> [f( Questionl) dx
Format Labels
Label Mumbering Prefix | Queskion
Label Mumbering Scheme | Flat Mumeric V
OF l [ Cancel

Figure 3.6: Format Labels Dialog: Adding a Prefix
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Features of Equation Labels

Although equation labels are not descriptive names, labels offer other important features.
» Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.

* Maple labels the output values sequentially. If you remove or insert an output, Maple automatically re-numbers all
equation labels and updates the label references.

» Ifyou change the equation label format (see Label Numbering Schemes (page 72)), Maple automatically updates
all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 68).
For more information on equation labels, refer to the equationlabels help page.

The following chapters describe how to use Maple to perform tasks such as solving equations, producing plots and
animations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where
noted, all features are available in both Worksheet mode and Document mode.
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4 Basic Computations

This chapter discusses key concepts related to performing basic computations with Maple. It discusses important features
that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve

problems in specific mathematical disciplines in the following chapter.

4.1 In This Chapter

Section

Topics

Symbolic and Numeric Computation (page 76)- An overview of
exact and floating-point computation

* Exact Computations
* Floating-Point Computations
» Converting Exact Quantities to Floating-Point Values

* Sources of Error

Integer Operations (page 79) - How to perform integer
computations

* Important Integer Commands
* Non-Base 10 Numbers
* Finite Rings and Fields

* Gaussian Integers

Solving Equations (page 82) - How to solve standard
mathematical equations

» Equations and Inequations

* Ordinary Differential Equations

* Partial Differential Equations

* Integer Equations

 Integer Equations in a Finite Field
* Linear Systems

¢ Recurrence Relations

Units, Scientific Constants, and Uncertainty (page 95) - How to
construct and compute with expressions that have units, scientific
constants, or uncertainty

Units

» Conversions

* Applying Units to an Expression

* Performing Computations with Units
* Changing the Current System of Units
 Extensibility

Scientific Constants

* Scientific Constants

» Element and Isotope Properties
¢ Value, Units, and Uncertainty

* Performing Computations

* Modification and Extensibility

Uncertainty Propagation

* Quantities with Uncertainty

» Performing Computations with Quantities with Uncertainty

75
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Section Topics

Restricting the Domain (page 105) - How to restrict the domain |« Real Number Domain

for computations » Assumptions on Variables

4.2 Symbolic and Numeric Computation

Symbolic computation is the mathematical manipulation of expressions involving symbolic or abstract quantities, such

as variables, functions, and operators; and exact numbers, such as integers, rationals, 1, and ez. The goal of such
manipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood
formulas.

Numeric computation is the manipulation of expressions in the context of finite-precision arithmetic. Expressions in-

volving exact numbers, for example, y/ 2, are replaced by close approximations using floating-point numbers, for
example 1.41421. These computations generally involve some error. Understanding and controlling this error is often
of as much importance as the computed result.

In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a
decimal point) or the evalf command. The plot command (see Plots and Animations (page 191)) uses numeric compu-
tation, while commands such as int, limit, and ged (see Integer Operations (page 79) and Mathematical Problem
Solving (page 111)) generally use only symbolic computation to achieve their results.

T 4.1
Exact Computations

In Maple, integers, rational numbers, mathematical constants such as © and oo, and mathematical structures such as
matrices with these as entries are treated as exact quantities. Names, such as X, y, my_variable, and mathematical
functions, such as sin(x) and LambertW(k, z), are symbolic objects. Names can be assigned exact quantities as
their values, and functions can be evaluated at symbolic or exact arguments.

b 4.2)

T
i, 1 + —
6 2
Important: Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact

quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approx-
imations, as you normally obtain from a standard hand-held calculator.
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> sin(1), sin(x), sin(x)

sin(1), 0, sin(x~)
> Jtan(t) dt
-In(cos(t))

>/ 32
4.2

Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required. For example, the plot command requires
the expression it is plotting to evaluate to numeric values that can be rendered on the screen: 7 cannot be so rendered,

but 3.14159 can be. Maple distinguishes approximate from exact quantities by the presence or absence of a decimal

point: 1.9 is approximate, while % is exact.

Note: An alternative representation of floating-point numbers, called e-notation, may not include an explicit decimal
point: 7e5 =100000., 3e-2 =.03.

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric
approximations. Arithmetic involving mixed exact and floating-point quantities results in a floating-point result.

T

>1.5+ %, 1+0.5~n

2.166666667, 2.570796327

If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approx-
imation of the result.

1.0
> sin(l.S),J e dx
0.0

0.9974949866, 1.718281828

Converting Exact Quantities to Floating-Point Values

To convert an exact quantity to a numeric approximation of that quantity, use the evalf command or the Approximate
context panel operation (see Approximating the Value of an Expression (page 51)).

> evalf(r), evalf(sin(3)), evalf(g—ké)

3.141592654, 0.1411200081, 1.833333333

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

* Locally, you can pass the precision as an index to the evalf call.
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> evalf[20](exp(2)), eva’f( r[g))

7.3890560989306502272, 1.354117939

* Globally, you can set the value of the Digits environment variable.

> Digits = 25 :
> evalf[tan[ % ] ]

For more information, see the evalf and Digits help pages.

1.732050807568877293527446

Note: When appropriate, Maple performs floating-point computations directly using your computer's underlying
hardware.

Sources of Error

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject
of active research in Numerical Analysis. Some sources of error are:

. . . 1
* An exact quantity may not be exactly representable in decimal form: —- and 7z are examples.

3
* Small errors can accumulate after many arithmetic operations.

 Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the

computation X — sin(x) for x = 0.

> (x—sin(x))
x=.00001

1.66666666665833 10 1°

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a represent-
ation that is more accurate for small values of X, a fully accurate 10-digit result can be obtained.

> t:= taylor(x—sin(x), x)

tm 1 X3 _ 1

1 5 7
=% 120X +O(x )

>t
x=0.00001
1.666666666658333333333334 10 ¢

For information on evaluating an expression at a point, see Substituting a Value for a Subexpression (page 285). For
information on creating a series approximation, see Series (page 135). For more information on floating-point numbers,
refer to the float and type/float help pages.
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4.3 Integer Operations

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated
integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the
greatest common divisor (GCD) of a pair of integers.

Note: Many integer operations are available as task templates (Tools—Tasks—Browse, under Integers).

You can quickly perform many integer operations using the context panel. Clicking on an integer displays the context
panel with integer commands. For example, the context-sensitive operation Integer Factors applies the ifactor command
to compute the prime factorization of the given integer. See Figure 4.1.

[> 9469629 - factor integer
(3)

9469629

Plot Builder
Explore

Apply a Command
Assign to a Mame
Divisors

Integer Factors

Plots >

Figure 4.1: Context Panel for an Integer
The result of applying Integer Factors is shown:
> 9469629
9469629 (4.3)

> ifactor((4.3))

(3)* (13) (17) (23)? (4.4)

Maple inserts the command ifactor, using an equation label reference to the integer 946929. For more information on
equation labels, see Equation Labels (page 70).

For more information on using context-sensitive operations in Worksheet mode, see The Context Panel (page 65). For
information on using context-sensitive operations in Document mode, see Computing with the Context Panel (page 49).

Maple has many other integer commands, including those listed in Table 4.1.

Table 4.1: Select Integer Commands

Command Description

abs absolute value (displays in 2-D math as |al)
factorial factorial (displays in 2-D math as a!)
ifactor prime factorization

iged greatest common divisor

iquo quotient of integer division
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Command Description

irem remainder of integer division

iroot integer approximation of nth root

isprime test primality

isqrt integer approximation of square root

max, min maximum and minimum of a set

mod modular arithmetic (See Finite Rings and Fields (page 81).)
NumberTheory[Divisors] set of positive divisors

> iquo(209,17)

12
> irem(209,17)

5
> igcd(2024, 4862)

22
> iroot(982523, 4)

31

For information on finding integer solutions to equations, see Integer Equations (page 93).

Non-Base 10 Numbers and Other Number Systems

Maple supports:
* Non-base 10 numbers
* Finite ring and field arithmetic

* Gaussian integers
Non-Base 10 Numbers
To represent an expression in another base, use the convert command.
> convert(6000, 'binary)
1011101110000

> convert(34271, 'heX)
85DF

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 290).

You can also use the convert/base command.

> convert(34271, 'base', 16)
[15,13,5, 8]

Note: The convert/base command returns a list of digit values in order of increasing significance.
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Finite Rings and Fields
Maple supports computations over the integers modulo m.
The mod operator evaluates an expression over the integers modulo m.
> 27 mod 4
3

By default, the mod operator uses positive representation (modp command). Symmetric representation is available
using the mods command.

> modp(27, 4)

> mods(27, 4)

-1
For information on setting symmetric representation as the default, refer to the mod help page.
The modular arithmetic operators are listed in Table 4.2.

Table 4.2: Modular Arithmetic Operators

Operation Operator |Example
Addition + >7 +6mod5s
3
Subtraction - > mods(3 — 16, 11)
A
Multiplication (displays in 2-D Math as - ) * > 13-5mod 3
2
TR - X ~
x;let;g:;gve inverse (displays in 2-D Math as a -1 >3 (-1 )mo as
2
Division (displays in 2-D Math as % ) ! > % mod 5
4
Exponentiation' &* > (100&*100)mod 7
2
'To enter a caret (™) in 2-D Math, enter a backslash character followed by a caret, that is, \.

For information on solving an equation modulo an integer, see Integer Equations in a Finite Field (page 94).

The mod operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information,
refer to the mod help page.
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Gaussian Integers
Gaussian integers are complex numbers in which the real and imaginary parts are integers.
The GaussInt package contains commands that perform Gaussian integer operations.

The GlIfactor command returns the Gaussian integer factorization.

> Gaussint| GIfactor](173 + 16 1)
(1+21) (41 —661)

In Maple, complex numbers are represented as a+b*I, where the uppercase I represents the imaginary unit / -1 .
You can also enter the imaginary unit using the following two methods.

* In the Common Symbols palette, click the I, i or j item. See Palettes (page 15).
» Enter i or j, and then press the symbol completion key. See Symbol Names (page 21).

Note that the output will still be displayed with I, no matter what symbol was used for input. You can customize Maple's

settings to use a different symbol for / -1 . For more information on entering complex numbers, including how to
customize this setting, refer to the HowDol/Enter AComplexNumber help page.

The GIsqrt command approximates the square root in the Gaussian integers.
> Gaussint[ GIsqrt] (9 — 5 j)
3 -1

For more information on Gaussian integers including a list of GaussInt package commands, refer to the GaussInt
help page.

4.4 Solving Equations
You can solve a variety of equation types, including those described in Table 4.3.

Table 4.3: Overview of Solution Methods for Important Equation Types

Equation Type Solution Method

Equations and inequations solve and fsolve commands

Ordinary differential equations ODE Analyzer Assistant (and dsolve command)
Partial differential equations pdsolve command

Integer equations isolve command

Integer equations in a finite field msolve command

Linear integral equations intsolve command

Linear systems LinearAlgebra|LinearSolve] command
Recurrence relations rsolve command

Note: Many solve operations are available in the context panel and as task templates (Tools—Tasks—Browse). Most
of this section focuses on other methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.
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To solve an equation or set of equations using the context panel:
1. Click the equation.

2. From the context panel, select Solve (or Solve Numerically). See Figure 4.2.

solve swap sides
fr

T 2
» —x —x=12
[ 3t

B! 12= -

L

Plot both sides

\/

72
—x" —x=12
3¥ X

Apply a Command

.......................... L - |
Kight-nand side
Simplify >
[Solve )i
Isolate Expression for L4
Mumerically Solve =
Mumerically Solve (w/complex) >
Mumerically Solve from point >
Obtain Solutions for L4 >
Solve >

Solve (explicit)
Solve (general solution)

Solve for Variable r

Figure 4.2: Context Panel for an Equation
In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.
If you select Solve, Maple computes exact solutions.

L 7X

=12
3 X

— X~ —=x~=12 4.5)

> solve( {(4.5)})

X~ =

3 3J/113 } |x~—i+3‘/113 “6)
14 0 '

14 14 14

If you select Solve Numerically, Maple computes floating-point solutions.
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> - x=12

7 X
3
— X~ —=x~=12 4.7

> fsolve( {(4.7)})
{x~=—2.063602674157424873142669}, {x~=2.492174102728853444571240} (4.8)

For information on solving equations and inequations symbolically using the solve command, see the following section.
For information on solving equations numerically using the fsolve command, see Numerically Solving
Equations (page 86).

Symbolically Solving Equations and Inequations

The solve command is a general solver that determines exact symbolic solutions to equations or inequations. The
solutions to a single equation or inequation are returned as an expression sequence. For details, see Creating and Using
Data Structures (page 269). If Maple does not find any solutions, the solve command returns the empty expression se-
quence.

> solve(f+3x+14 =0)

In general, solve computes solutions in the field of complex numbers. To restrict the problem to only real solutions,
see Restricting the Domain (page 105).

It is recommended that you verify the solutions returned by the solve command. For details, see Working with
Solutions (page 87).

To return the solutions as a list, enclose the calling sequence in brackets ([ ]).
> [solve(x2 + x=256Y, x)]

1, J1+1024y 1 JT+102dy

2 2 2 2

Expressions: You can specify expressions instead of equations. The solve command automatically equates them to
ZEero.

> solve(e” + z)
-LambertW(1)
(In this case, the solution involves the LambertW function.)

Multiple Equations: To solve multiple equations or inequations, specify them as a list or set. For an introduction to
both lists and sets, see Creating and Using Data Structures (page 269).
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> Solve([xy2 —y=5x> 0]

kx~:m,—5 <y,y<0}, [x~:—,0<y’

);
> solve({xy2 —y=5x< 0})

{x~= M,y< —5}

y2

Solving for Specific Unknowns: By default, the solve command returns solutions for all unknowns. You can specify
the unknowns for which to solve.

> solve(q‘2 — rs+% =5, q)

1+/4rs420 1 1+/4r 5420 11
2r ’ 2r

To solve for multiple unknowns, specify them as a list.

qa__r .4q._ -
>solve({s S+1+r 5, rs 1],[6],1"])

St +s+1 S

l 58 +5s+1 _1]
q=———+ L, Fr=—

Transcendental Equations: In general, the solve command returns one solution to transcendental equations.
> equationl := sin(x) = cos(x) :

> solve(equationl)

K3
4
To produce all solutions, use the allsolutions option.

> solve(equationl, allsolutions = true)

1
—n+n_Zl~
4 T+T

Maple uses variables of the form _ZN~, where N is a positive integer, to represent arbitrary integers. The tilde (~) in-
dicates that it is a quantity with an assumption. For information about names with assumptions, see Assumptions on
Variables (page 106).

RootOf Structure: The solve command may return solutions, for example, to higher order polynomial equations, in
an implicit form using RootOf structures.
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> [SOlve(x5 —2x 43X - 2)]

[1] (4.9)
These RootOf structures are placeholders for the roots of the equation 77 +2 7 + 2 z 4 2. The index para-
meter numbers and orders the four solutions.

Like any symbolic expression, you can convert RootOf structures to a floating-point value using the evalf command.

> evalf((4.9))
[1.]

Some equations are difficult to solve symbolically. For example, polynomial equations of order five and greater do
not in general have a solution in terms of radicals. If the solve command does not find any solutions, it is recommended
that you use the Maple numerical solver, fsolve. For information, see the following section, Numerically Solving
Equations.

For more information on the solve command, including how to solve equations defined as procedures and how to find
parametric solutions, refer to the solve/details help page.

For information on verifying and using solutions returned by the solve command, see Working with Solutions (page 87).

Numerically Solving Equations

The fsolve command solves equations numerically. The behavior of the fsolve command is similar to that of the solve
command.

> equation2:= z cos(z) = 2:
> fsolve(equation2)
23.64662473459662857915842 (4.10)

Note: You can also numerically solve equations using the context panel. See Solving Equations and
Inequations (page 82).

It is recommended that you verify the solutions returned by the fsolve command. For details, see Working with
Solutions (page 87).

Multiple Equations: To solve multiple equations, specify them as a set. For more information, see Creating and Using
Data Structures (page 269). The fsolve command solves for all unknowns.

> fsolve({In(x) =% + 1,xy=¢"})
{x~=3.396618822958834043247827,y =0.4719962637344134726551666}

Univariate Polynomial Equations: In general, the fsolve command finds one real solution. However, for a univariate
polynomial equation, the fsolve command returns all real roots.

> equation3:=y4 -3 y2 —2y+1:

> fsolve(equation3, y)

0.3365322739267902638565395, 1.940392663660670332844725

Controlling the Number of Solutions: To limit the number of roots returned, specify the maxsols option.
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> fsolve(equation3, y,maxsols'= 1)

0.3365322739267902638565395
To find additional solutions to a general equation, use the avoid option to ignore known solutions.
> fsolve(equation2, z,'avoid = {z = (4.10) })

—2.498755762652414667125417

Complex Solutions: To search for a complex solution or find all complex and real roots for a univariate polynomial,
specify the complex option for the fsolve command.

> fsolve(equation3, y, 'complex)

—1.138462468793730298350632 — 0.4850624940594346587957853 ],
—1.138462468793730298350632 + 0.4850624940594346587957853 ],
0.3365322739267902638565395, 1.940392663660670332844725

If the fsolve command does not find any solutions, it is recommended that you specify a range in which to search for
solutions, or specify an initial value.

Range: To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.
> fsolve(equation2, z, {z =100..200})
199.5011586753119377854826
The syntax for specifying a region in the complex plane is lower-left point..upper-right point.
> fsolve(equation3,y, {y = -2 — 1..0}, 'compleX);
—1.138462468793730298350632 — 0.4850624940594346587957853 1

Initial Values: You can specify a value for each unknown. The fsolve command uses these as initial values for the
unknowns in the numerical method.

> fsolve(equation2, {z = 100})
{z=98.98037598878310465489182} (4.11)

For more information and examples, refer to the fsolve/details help page.

For information on verifying and using solutions returned by the fsolve command, see the following section, Working
with Solutions.

Working with Solutions

Verifying: It is recommended that you always verify solutions (that the solve and fsolve commands return) using the
eval command.

> equation4 := sin(x) = —cos(x):
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> solve(equation4)

T (4.12)

> eval(equation4,x= (4.12))

> equation5:= cos(z) = %:

> fsolve(equation5)
—2.498755762652414667125417 (4.14)
> eval(equation5, {z= (4.14) })
—0.8003983542101016170344244 = —0.8003983542101016170344242 (4.15)
For more information, see Substituting a Value for a Subexpression (page 285).

Assigning the Value of a Solution to a Variable: To assign the value of a solution to the corresponding variable as
an expression, use the assign command.

For example, consider the numeric solution in (4.11), {z =98.98037598878310465489182}, found using
the starting value z = 100.

> assign((4.11))

>z
98.98037598878310465489182

Creating a Function from a Solution: The assign command assigns a value as an expression to a name. It does not
define a function. To convert a solution to a function, use the unapply command.

Consider one of the solutions for q to the equation q2 —rs+ % =5.

> solutions:=

Solve(q2 —rs+ % =5, q”

. —1+\/4r33+20r2+1 1+\/4r33+20r2+1
solutions := , -

2r 2r

> f:= unapply(solutions[1] ,r, s)

1+J4rs+207 +1
2r

f=(rs)

Here, solutions[1] selects the first element of the list of solutions. For more information on selecting elements, see
Accessing Elements (page 269).
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You can evaluate this function at symbolic or numeric values.

> f(x, )

>

>

1 +J4x3yr20x2 41
2 X~

=)
J2 ((1+/y2 +11)

2

£(5.7,2.1)
4.032680521587978641060188

For more information on defining and using functions, see Functional Operators (page 273).

Other Specialized Solvers

In addition to equations and inequations, Maple can solve other equations including:

3

Ordinary differential equations (ODEs)
Partial differential equations (PDEs)
Integer equations

Integer equations in a finite field
Linear systems

Recurrence relations

Ordinary Differential Equations (ODEs)

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and nu-
merically.

ODE Analyzer Assistant The ODE Analyzer Assistant is a point-and-click interface to the Maple ODE solving
routines.

To open the ODE Analyzer:

3

From the Tools menu, select Tutors, Differential Equations, and then ODE Analyzer.

Maple inserts the dsolve[interactive]() calling sequence in the document. The ODE Analyzer Assistant (Figure 4.3)
is displayed.



90 < 4 Basic Computations

(%] oDE Analyzer Assistant
Differential Equations Conditions Paramekers
& gle) _ 4(0)=0 =1
L=1
m=2

[ Solve Mumerically ” Solve Symbalically ” Classify

Figure 4.3: ODE Analyzer Assistant

In the main ODE Analyzer Assistant window, you can define ODEs, initial or boundary value conditions, and para-

df
dxl

meters. To define derivatives, use the diff command. For example, diff (x (t) , t) corresponds to and

2
diff(x(t), t, t) correspondsto ﬂ For more information on the diff command, see The diff

dx’

Command (page 132).
After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:
1. Ensure that the conditions guarantee uniqueness of the solution.

2. Ensure that all parameters have fixed values.

3. Click the Solve Numerically button.
4

. In the Solve Numerically window (Figure 4.4), you can specify the numeric method and relevant parameters and
error tolerances to use for solving the problem.

5. To compute solution values at a point, click the Solve button.
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3 Solve Humerically

Parameters

(+) Runge-kKutta-Fehlberg 4-5th order
(") Cash-Karp 4-5th order
() Dwerk. 7-8th order
(") ear single step extrapolation
() Rasenbrock stiff 3-4th order

() Livermore: stiff

() Boundary Value Problem salver

() Taylor series

(") Modified Extended BOF Implicit

() Fixed step methads

Absolute: |1,000000e-07 default
Relative:  1,000000e-06 default

On Quit, Return | Plok
X

Figure 4.4: ODE Analyzer Assistant: Solve Numeri

Cukpuk
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Plat Options
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Show Maple commands
s0ll = dsolve|[diff (diffig(t), L), Cl+g(L])
= 4%cos(2%t), o(0) = 0, Dig)(0) = 0],
numeric) ;
=0ll(1.0000007 ;
plots[odeplot] (soll, O0..10, color = red):

[ Clear ][ Help ][ Back. ][ ik ]

cally Dialog

To solve a system symbolically using the ODE Analyzer Assistant:

1. Click the Solve Symbolically button.

2. In the Solve Symbolically window (Figure 4.5), you can specify the method and relevant method-specific options
to use for solving the problem.

3. To compute the solution, click the Solve button.
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%] Solve Symbolically
Method Cutput
@ Defaut timelimit (s) = &0
N r 4 4 .
Use Lie Methads q(f]=?605(1]-?605'(2£]

Use Classification Methods
Integrate auko :Vl'-
Explicik
() TransForms

() Truncated Series, order=

Plot COptions

Expansion point 1 f \ ;f \\

Shiws Maple commands 4 | | \ / \

lsoll := 1] \ | f '
|dsolve [ [Aiff (diff {q(T \ ' \
[1ati,th+uie) = : ' ' '
4%eos(2%t), o(0) = 0O, | \ f \ |
D(g) (D) = O], | ~2. |

| ; | \
{olt)h)s /
|plot (4/3%cos () -4/3%c 'v_';. \‘«’ \Uj

20 Quik, Return| Solution [+ [ Clear ][ Help ][ Back. ][ ik ]

Figure 4.5: ODE Analyzer Assistant: Solve Symbolically Dialog

When solving numerically or symbolically, you can view a plot of the solution by clicking the Plot button.
* To plot the solution to a symbolic problem, all conditions and parameters must be set.

* To customize the plot, click the Plot Options button to open the Plot Options window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the Show Maple
commands check box.

You can control the return value of the ODE Analyzer using the On Quit, Return drop-down list. You can select to
return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic
solutions), or the Maple commands needed to produce the solution values and the displayed plot.

For more information, refer to the ODEAnalyzer help page.
The dsolve Command
The ODE Analyzer provides a point-and-click interface to the Maple dsolve command.

For ODEs or systems of ODEs, the dsolve command can find:
* Closed form solutions

¢ Numerical solutions
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¢ Series solutions

In addition, the dsolve command can find:
» Formal power series solutions to linear ODEs with polynomial coefficients

» Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the dsolve command directly. For more information, refer to the dsolve help
page.

Partial Differential Equations (PDEs)

To solve a PDE or PDE system symbolically or numerically, use the pdsolve command. PDE systems can contain
ODEzs, algebraic equations, and inequations.

For example, solve the following PDE symbolically. For help entering a partial derivative, see Example I - Enter a
Partial Derivative (page 45).

> unassign('f’)

> X[a—ayf(x, y))—y[%f(& »)=0

x~ [a—ay fx=) —y(ax% flx=)] =0 @.16)

> pdsolve((4.16))
f(x~y) = _F1(x~* + )

The solution is an arbitrary univariate function applied to X + )/2 .

Maple generally prints only the return value, errors, and warnings during a computation. To print information about
the techniques Maple uses, increase the infolevel setting for the command.

To return all information, set infolevel to 5.
> infolevel| pdsolve] :=5 :

> pdsolve((4.16))

Checking arguments ...

First set of solution methods (general or quasi general solution)
Trying characteristic strip method for first order PDEs
characteristic strip method for first order PDEs successful
First set of solution methods successful
<- Returning a *general* solution

f(x~¥) = _FI(x~* + )

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the pdsolve
help page.

Integer Equations

To find only integer solutions to an equation, use the isolve command. The isolve command finds solutions for all
variables. For more information, refer to the isolve help page.
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> isolve( {XZ +y= 13})
{x~=_z1,y=-_z1° + 13}

Integer Equations in a Finite Field
To solve an equation modulo an integer, use the msolve command. The msolve command finds solutions for all variables.
For more information, refer to the msolve help page.
> msolve( {xz = 1}, 1 3)
{x~=1} {x~=12}

Solving Linear Systems

To solve a linear system, use the LinearAlgebra[LinearSolve] command. The LinearSolve command returns the
vector x that satisfies A . x = B. For more information, refer to the LinearAlgebra[LinearSolve] help page.

For example, construct an augmented matrix using the Matrix palette (see Creating Matrices and Vectors (page 118))
in which the first four columns contain the entries of A and the final column contains the entries of B.

59 44 17 1 1

10 25 2 100 2

533 61

] L 0 7 100 50
> linearsystem := :

og 2L 3, 2178

10 10 25

51 786

23 9 12 10 >s

> LinearAlgebra[ LinearSolve](linearsystem)

31753441047 |
41858667400

16991806239
8371733480

1489266217
1674346696

262603866
209293337

For more information on using Maple to solve linear algebra problems, see Linear Algebra (page 118).

Solving Recurrence Relations

To solve a recurrence relation, use the rsolve command. The rsolve command finds the general term of the function.
For more information, refer to the rsolve help page.
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> rsolvel{fin)= fin- 1)+ fin-2), 0)= 1, fl1)= 1}{f(n)}))
[f(,,):[1+ﬁJ(1 ﬁ]”+(1_ﬁ](1_ﬁjn]

2 10 2 2 2 10 2 2

4.5 Units, Scientific Constants, and Uncertainty

In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and
uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom
units.

Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

Units

The Units package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible
so that you can add units and unit systems as required.

Note: Some unit operations are available as task templates (see Tools—Tasks—Browse) and through the context
panel.

Overview of Units

A dimension is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and
independent are known as base dimensions.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of
substance, luminous intensity, information, and currency. For a complete list, enter and execute Units[ GetDimensions]().

Complex dimensions (or composite dimensions) measure other quantities in terms of a combination of base dimensions.

mass-length

time

For example, the complex dimension force is a measurement of

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure
a complex dimension.) Maple supports over 40 units of length, including feet, miles, meters, angstroms, microns, and
astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.

Table 4.4 lists some dimensions, their corresponding base dimensions, and example units.

Table 4.4: Sample Dimensions

Dimension Base Dimensions Example Units

Time time second, minute, hour, day, week, month, year,
millennium, blink, lune

Energy joule, electron volt, erg, watt hour, calorie,

2
length’”-mass Calorie, British thermal unit

time2

Electric potential volt, abvolt, statvolt

length2 -mass

time3 -electric current

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding
help page, for example, the Units/length help page for the units of length.
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Each unit has a context. The context differentiates between different definitions of the unit. For example, the standard
and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the
context for a unit by appending the context as an index to the unit, for example, mile[US_survey]. If you do not specify
a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or systéme
international, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound,
and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI,
the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed,
magnetic flux, and power are the meter/second, weber, and watt, respectively.

Unit Conversions

To convert a value measured in a unit to the corresponding value in a different unit, use the Units Converter.

* From the Tools— Assistants menu, select Units Converter.

The Units Converter application (Figure 4.6) opens.

Units Converter

Convert between over 500 units of measurement. See Units help index for details.

First, select a dimension from the drop-down box. Then select the units to convert from and to. Click the "Perform
Unit Conversion" button. The "Convert Back" button converts in the opposite direction.

Convert Result 2831684659

From: cubic feet (ft"3) O To: cubic meters (m*3) -

Dimension: volume b

‘ Perform Unit Conversion ‘ ‘ Convert Back

Figure 4.6: Units Converter Assistant

To perform a conversion:

1. In the Convert text field, enter the numeric value to convert.

2. In the Dimension drop-down list, select the dimensions of the unit.

3. In the From and To drop-down lists, select the original unit and the unit to which to convert.

4. Click Perform Unit Conversion.

The same conversion can be done with the convert/units command.
> convert(1.0, 'units', " Ibf ft(radius)', ' N m(radius)’)
1.355817948331400400000000

Using the Units Converter, you can convert temperatures and temperature changes.
» To perform a temperature conversion, in the Dimension drop-down list, select temperature(absolute).

» To perform a temperature change conversion, in the Dimension drop-down list, select temperature(relative).

To convert temperature changes, the Units Converter uses the convert/units command. For example, an increase of
32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.
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> convert(32.0, 'units', ' degF', ' degC")
17.77777777777777777777778

To convert absolute temperatures, the Unit Converter uses the convert/temperature command. For example, 32 degrees
Fahrenheit corresponds to 0 degrees Celsius.

> convert(32, ' temperature', ' degF', ' degC")
0

Applying Units to an Expression

To insert a unit, use the Units palette . See Figure 4.7.

¥ Units
Dimensianality:

_Iengﬂn - |
A ft n

m  micron
mi vd km

cm mim nm

unit

Figure 4.7: Units Palette

To insert a unit:

* In the Units palette, select a unit dimension, then click the desired unit symbol.

> 3ft
3 ft
To insert a unit that is unavailable in the palettes:
unit
1. In the Units palette, click the unit symbol [+. Maple inserts a Unit object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol). Note that you see double brackets around the unit when you
are editing it.

For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.
As you edit, the unit is enclosed in double brackets: 0-01[mile]
> (0.01mile

0.01 mi

The context of a unit is displayed only if it is not the default context.

Alternative ways to enter units:
* Enter Unit, and then press the symbol completion key (see Symbol Names (page 21)) and then enter the unit.
» Use the shortcut key Ctrl + Shift + U (Command + Shift + U, on Mac) and then enter the unit.
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+ Use the Unit command. Note that to write a quantity with a unit using this command, write multiplication between
them; this is especially evident in 1-D math:

Important: In 1-D Math input, the quantity and unit (entered using the top-level Unit command) are a product, not a
single entity. The following calling sequences define different expressions.

> 1*Unit(m)/ (2*Unit(s)); > 1*Unit (m) /2*Unit(s) ;
1m 1
2 s 2

Some units support prefixes. For example, SI units support prefixes to names and symbols. You can specify 1000
meters using kilometer or km. For more information, refer to the Units/prefixes help page.

> 1.5[[km51]]
1.5 km

Performing Computations with Units

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform
only unit conversions. For more information about the default environment, refer to the Units/Default help page.

To compute with expressions that have units, you mus<ns1:XMLFault xmlns:ns1="http://cxf.apache.org/bindings/xformat"><ns1:faultstring xmlns:ns1="http://cxf.apache.org/bindings/xformat">java.lang.OutOfMemoryError: Java heap space</ns1:faultstring></ns1:XMLFault>